summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-30 01:51:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-30 01:51:45 +0000
commit18871c83f8729fe47d5cd4ceeeb508c3f156c385 (patch)
tree912aed9492fb7308b60bad495b39377d2f400400 /package/openssl
parentbcd137f5ffd0f28c7ba813bce8eab1461764e6dc (diff)
downloadbuildroot-novena-18871c83f8729fe47d5cd4ceeeb508c3f156c385.tar.gz
buildroot-novena-18871c83f8729fe47d5cd4ceeeb508c3f156c385.zip
ver bump by gnat in Bug 452 and make sure we configure as i386 with i[456]86 targets by schieli in Bug 450
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index af0266ea9..f9b8e96a1 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -5,11 +5,17 @@
#############################################################
# TARGETS
-OPENSSL_VER:=0.9.7e
+OPENSSL_VER:=0.9.8
OPENSSL_SITE:=http://www.openssl.org/source
OPENSSL_SOURCE:=openssl-$(OPENSSL_VER).tar.gz
OPENSSL_DIR:=$(BUILD_DIR)/openssl-$(OPENSSL_VER)
+ifeq ($(BR2_i386),y)
+OPENSSL_TARGET_ARCH:=i386-$(ARCH)
+else
+OPENSSL_TARGET_ARCH:=$(ARCH)
+endif
+
$(DL_DIR)/$(OPENSSL_SOURCE):
$(WGET) -P $(DL_DIR) $(OPENSSL_SITE)/$(OPENSSL_SOURCE)
@@ -26,7 +32,7 @@ $(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE)
$(OPENSSL_DIR)/Makefile: $(OPENSSL_DIR)/.unpacked
(cd $(OPENSSL_DIR); \
CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5 $(TARGET_CFLAGS)" \
- PATH=$(TARGET_PATH) ./Configure linux-$(ARCH) --prefix=/ \
+ PATH=$(TARGET_PATH) ./Configure linux-$(OPENSSL_TARGET_ARCH) --prefix=/ \
--openssldir=/usr/lib/ssl -L$(STAGING_DIR)/lib -ldl \
-I$(STAGING_DIR)/include $(OPENSSL_OPTS) no-threads \
shared no-idea no-mdc2 no-rc5)