summaryrefslogtreecommitdiffstats
path: root/package/openssh
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-02-07 10:55:04 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-07 14:34:28 +0100
commitc761eafb021c2beaf52b2d1a383433deac5fc2b4 (patch)
tree935fd5078ab7996923ca8c45e6358df1798dcebc /package/openssh
parentc574441c2a79d2bf29560ff146112cf85d6f36b1 (diff)
downloadbuildroot-novena-c761eafb021c2beaf52b2d1a383433deac5fc2b4.tar.gz
buildroot-novena-c761eafb021c2beaf52b2d1a383433deac5fc2b4.zip
openssl: pass LDFLAGS to fix incorrect link
We already pass the LD variable to openssl in order to use gcc as the driver for the link process, instead of directly using the ld linker. However, we were not passing LDFLAGS so that the compiler flags are passed, which means that with multilib toolchains, the incorrect library variant could be used at link time, leading to invalid binaries (partly ARMv4, partly ARMv5) or broken compilation (when the build took place in soft-float, but the link stage takes place against hard-float libraries). This fixes a problem reported on IRC by amo-ej1 when compiling ssh on PowerPC e500v2 with a CodeSourcery toolchain ("crtbegin.o uses hard float, sshd uses soft float"). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openssh')
-rw-r--r--package/openssh/openssh.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 82c64d631..3db7156cb 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -6,7 +6,7 @@
OPENSSH_VERSION = 5.6p1
OPENSSH_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable
-OPENSSH_CONF_ENV = LD="$(TARGET_CC)"
+OPENSSH_CONF_ENV = LD="$(TARGET_CC)" LDFLAGS="$(TARGET_CFLAGS)"
OPENSSH_CONF_OPT = --libexecdir=/usr/lib --disable-lastlog --disable-utmp \
--disable-utmpx --disable-wtmp --disable-wtmpx --disable-strip