summaryrefslogtreecommitdiffstats
path: root/package/openssh
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-02-11 10:27:18 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-14 22:22:05 +0100
commitc1bb0979999318397a014b9fcce727948153bf4f (patch)
tree2fc9239aef7c4c9c531a298c0206f2a4d740f37f /package/openssh
parent4120e051f6c1721dbe9419e5942df833ba53159e (diff)
downloadbuildroot-novena-c1bb0979999318397a014b9fcce727948153bf4f.tar.gz
buildroot-novena-c1bb0979999318397a014b9fcce727948153bf4f.zip
openssh: security bump to version 5.8p1
http://www.openssh.com/txt/legacy-cert.adv CVE-2011-0539 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openssh')
-rw-r--r--package/openssh/S50sshd8
-rw-r--r--package/openssh/openssh.mk2
2 files changed, 9 insertions, 1 deletions
diff --git a/package/openssh/S50sshd b/package/openssh/S50sshd
index 3821449fb..f0d2aef5a 100644
--- a/package/openssh/S50sshd
+++ b/package/openssh/S50sshd
@@ -25,6 +25,14 @@ if [ ! -f /etc/ssh_host_dsa_key ] ; then
echo
/usr/bin/ssh-keygen -t dsa -f /etc/ssh_host_dsa_key -C '' -N ''
fi
+
+# Check for the SSH2 ECDSA key
+if [ ! -f /etc/ssh_host_ecdsa_key ]; then
+ echo Generating ECDSA Key...
+ echo THIS CAN TAKE A MINUTE OR TWO DEPENDING ON YOUR PROCESSOR!
+ echo
+ /usr/bin/ssh-keygen -t ecdsa -f /etc/ssh_host_ecdsa_key -C '' -N ''
+fi
umask 077
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 3db7156cb..104977e48 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -4,7 +4,7 @@
#
#############################################################
-OPENSSH_VERSION = 5.6p1
+OPENSSH_VERSION = 5.8p1
OPENSSH_SITE = http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable
OPENSSH_CONF_ENV = LD="$(TARGET_CC)" LDFLAGS="$(TARGET_CFLAGS)"
OPENSSH_CONF_OPT = --libexecdir=/usr/lib --disable-lastlog --disable-utmp \