summaryrefslogtreecommitdiffstats
path: root/package/openpgm/openpgm.mk
diff options
context:
space:
mode:
authorAlexander Lukichev <alexander.lukichev@espotel.com>2013-03-03 23:48:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-17 16:02:13 +0100
commite019b10ac25e0876b4706a584842be4595b8fd2b (patch)
tree31c371b49cc11b5d4a32b20cec3d2783fbda4b7b /package/openpgm/openpgm.mk
parent3cc2cdb72fde97e211c42f67dc7973e051f95494 (diff)
downloadbuildroot-novena-e019b10ac25e0876b4706a584842be4595b8fd2b.tar.gz
buildroot-novena-e019b10ac25e0876b4706a584842be4595b8fd2b.zip
openpgm: new package
OpenPGM is an open source implementation of the Pragmatic General Multicast (PGM) specification in RFC 3208 available at www.ietf.org. It is required for PGM/EPGM support in ZeroMQ library. Signed-off-by: Alexander Lukichev <alexander.lukichev@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openpgm/openpgm.mk')
-rw-r--r--package/openpgm/openpgm.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/openpgm/openpgm.mk b/package/openpgm/openpgm.mk
new file mode 100644
index 000000000..c47601445
--- /dev/null
+++ b/package/openpgm/openpgm.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# openpgm
+#
+#############################################################
+
+OPENPGM_VERSION = 5.1.118~dfsg
+OPENPGM_SOURCE = libpgm-$(OPENPGM_VERSION).tar.gz
+OPENPGM_SITE = http://openpgm.googlecode.com/files/
+OPENPGM_LICENSE = LGPLv2.1+
+OPENPGM_LICENSE_FILES = openpgm/pgm/LICENSE
+OPENPGM_INSTALL_STAGING = YES
+OPENPGM_AUTORECONF = YES
+OPENPGM_SUBDIR = openpgm/pgm/
+OPENPGM_CONF_ENV = ac_cv_file__proc_cpuinfo=yes ac_cv_file__dev_rtc=no \
+ ac_cv_file__dev_hpet=no
+
+$(eval $(autotools-package))