summaryrefslogtreecommitdiffstats
path: root/package/openntpd
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-19 21:13:08 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-19 21:13:08 +0000
commit5036dd45b2171031bf2754731c352add91fd1e40 (patch)
treeff7d36c34fd2ac29f64d2665d04202541c447e59 /package/openntpd
parent78f528763b9d011e3f86a4976e49e2e6866348d4 (diff)
downloadbuildroot-novena-5036dd45b2171031bf2754731c352add91fd1e40.tar.gz
buildroot-novena-5036dd45b2171031bf2754731c352add91fd1e40.zip
openntpd cleanup
Diffstat (limited to 'package/openntpd')
-rw-r--r--package/openntpd/openntpd.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/package/openntpd/openntpd.mk b/package/openntpd/openntpd.mk
index 54e3e977f..04e689388 100644
--- a/package/openntpd/openntpd.mk
+++ b/package/openntpd/openntpd.mk
@@ -29,9 +29,11 @@ $(OPENNTPD_DIR)/.configured: $(OPENNTPD_DIR)/.source
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--sysconfdir=/etc \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
--with-builtin-arc4random \
- );
- touch $(OPENNTPD_DIR)/.configured;
+ )
+ touch $@
$(OPENNTPD_DIR)/$(OPENNTPD_BINARY): $(OPENNTPD_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) -C $(OPENNTPD_DIR)
@@ -45,22 +47,24 @@ $(OPENNTPD_DIR)/$(OPENNTPD_BINARY): $(OPENNTPD_DIR)/.configured
# ntpd.c buffer.c log.c imsg.c ntp.c ntp_msg.c y.tab.c config.c \
# server.c client.c sensors.c util.c ; \
#)
- $(STRIP) -s $@
+ $(STRIP) $@
$(TARGET_DIR)/$(OPENNTPD_TARGET_BINARY): $(OPENNTPD_DIR)/$(OPENNTPD_BINARY)
rm -f $(TARGET_DIR)/etc/ntpd.conf
$(MAKE) DESTDIR=$(TARGET_DIR) STRIP_OPT="" -C $(OPENNTPD_DIR) install
-$(STRIP) $(TARGET_DIR)/$(OPENNTPD_TARGET_BINARY)
cp -af $(OPENNTPD_DIR)/ntpd.conf $(TARGET_DIR)/etc/ntpd.conf
- rm -Rf $(TARGET_DIR)/usr/man
+ # Why in earth do we wipe the whole man directory here?
+ #rm -Rf $(TARGET_DIR)/usr/man
ntpd: uclibc $(TARGET_DIR)/$(OPENNTPD_TARGET_BINARY)
ntpd-source: $(DL_DIR)/$(OPENNTPD_SOURCE)
ntpd-clean:
- -$(MAKE) DESTDIR=$(TARGET_DIR) -C $(OPENNTPD_DIR) uninstall
- rm -f $(TARGET_DIR)/etc/ntpd.conf $(TARGET_DIR)/$(OPENNTPD_TARGET_BINARY)
+ rm -f $(addprefix $(TARGET_DIR)/,etc/ntpd.conf \
+ usr/share/man/man?/ntpd.conf* \
+ $(OPENNTPD_TARGET_BINARY))
-$(MAKE) -C $(OPENNTPD_DIR) clean
ntpd-dirclean: