summaryrefslogtreecommitdiffstats
path: root/package/opengl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-06 10:22:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-06 22:07:56 +0100
commit5e6696713c20615d0c1fdbafb8189fce9992e534 (patch)
tree551a0ac86e723eed585822ee7e2c1eb0c4ed3a39 /package/opengl
parent09fef507b03decc2dcc9a520c5a0bd8fd23ae34c (diff)
downloadbuildroot-novena-5e6696713c20615d0c1fdbafb8189fce9992e534.tar.gz
buildroot-novena-5e6696713c20615d0c1fdbafb8189fce9992e534.zip
package: create virtual package for libGLES, libOpenVG and libEGL
Those acceleration libraries typically have multiple implementations: some are free (Mesa), some are proprietary (generally SoC specific). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/opengl')
-rw-r--r--package/opengl/Config.in8
-rw-r--r--package/opengl/libegl/libegl.mk16
-rw-r--r--package/opengl/libgles/libgles.mk16
-rw-r--r--package/opengl/libopenvg/libopenvg.mk16
-rw-r--r--package/opengl/opengl.mk1
5 files changed, 57 insertions, 0 deletions
diff --git a/package/opengl/Config.in b/package/opengl/Config.in
new file mode 100644
index 000000000..81616f99f
--- /dev/null
+++ b/package/opengl/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HAS_OPENGL_EGL
+ bool
+
+config BR2_PACKAGE_HAS_OPENGL_ES
+ bool
+
+config BR2_PACKAGE_HAS_OPENVG
+ bool
diff --git a/package/opengl/libegl/libegl.mk b/package/opengl/libegl/libegl.mk
new file mode 100644
index 000000000..56cc8ac0d
--- /dev/null
+++ b/package/opengl/libegl/libegl.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libEGL
+#
+#############################################################
+
+LIBEGL_SOURCE =
+
+ifeq ($(LIBEGL_DEPENDENCIES),y)
+define LIBEGL_CONFIGURE_CMDS
+ echo "No libEGL implementation selected. Configuration error."
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/libgles/libgles.mk b/package/opengl/libgles/libgles.mk
new file mode 100644
index 000000000..753f53efe
--- /dev/null
+++ b/package/opengl/libgles/libgles.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libGLES
+#
+#############################################################
+
+LIBGLES_SOURCE =
+
+ifeq ($(LIBGLES_DEPENDENCIES),y)
+define LIBGLES_CONFIGURE_CMDS
+ echo "No libGLES implementation selected. Configuration error."
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/libopenvg/libopenvg.mk b/package/opengl/libopenvg/libopenvg.mk
new file mode 100644
index 000000000..2fcc99fa3
--- /dev/null
+++ b/package/opengl/libopenvg/libopenvg.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libOpenVG
+#
+#############################################################
+
+LIBOPENVG_SOURCE =
+
+ifeq ($(LIBOPENVG_DEPENDENCIES),y)
+define LIBOPENVG_CONFIGURE_CMDS
+ echo "No libOpenVG implementation selected. Configuration error."
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/opengl.mk b/package/opengl/opengl.mk
new file mode 100644
index 000000000..68df3b171
--- /dev/null
+++ b/package/opengl/opengl.mk
@@ -0,0 +1 @@
+include package/opengl/*/*.mk