summaryrefslogtreecommitdiffstats
path: root/package/opengl
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2013-05-30 14:08:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-30 15:42:45 +0200
commit14470b325935ee8a0ef8b73b33827ab633c1366f (patch)
tree6cc17b1e78f289b2fab92a0da5919ff9f9e65613 /package/opengl
parent7183fc0f3fefc9722bcd1f1be6ca02cdbfe0eb57 (diff)
downloadbuildroot-novena-14470b325935ee8a0ef8b73b33827ab633c1366f.tar.gz
buildroot-novena-14470b325935ee8a0ef8b73b33827ab633c1366f.zip
opengl: correct detection of virtual packages having no dependencies
I believe the original intent was to make it that the configure step for the opengl virtual packages fails if there is not at least one dependency. This patch fixes the logic so that it actually fails if dependency list is empty Signed-off-by: Will Wagner <will_wagner@carallon.com> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/opengl')
-rw-r--r--package/opengl/libegl/libegl.mk2
-rw-r--r--package/opengl/libgles/libgles.mk2
-rw-r--r--package/opengl/libopenvg/libopenvg.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/opengl/libegl/libegl.mk b/package/opengl/libegl/libegl.mk
index c4954963c..8ff24e886 100644
--- a/package/opengl/libegl/libegl.mk
+++ b/package/opengl/libegl/libegl.mk
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
LIBEGL_DEPENDENCIES += rpi-userland
endif
-ifeq ($(LIBEGL_DEPENDENCIES),y)
+ifeq ($(LIBEGL_DEPENDENCIES),)
define LIBEGL_CONFIGURE_CMDS
echo "No libEGL implementation selected. Configuration error."
exit 1
diff --git a/package/opengl/libgles/libgles.mk b/package/opengl/libgles/libgles.mk
index f0d0eec9c..675d11fd3 100644
--- a/package/opengl/libgles/libgles.mk
+++ b/package/opengl/libgles/libgles.mk
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
LIBGLES_DEPENDENCIES += rpi-userland
endif
-ifeq ($(LIBGLES_DEPENDENCIES),y)
+ifeq ($(LIBGLES_DEPENDENCIES),)
define LIBGLES_CONFIGURE_CMDS
echo "No libGLES implementation selected. Configuration error."
exit 1
diff --git a/package/opengl/libopenvg/libopenvg.mk b/package/opengl/libopenvg/libopenvg.mk
index 573fa786d..746b52c9a 100644
--- a/package/opengl/libopenvg/libopenvg.mk
+++ b/package/opengl/libopenvg/libopenvg.mk
@@ -10,7 +10,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
LIBOPENVG_DEPENDENCIES += rpi-userland
endif
-ifeq ($(LIBOPENVG_DEPENDENCIES),y)
+ifeq ($(LIBOPENVG_DEPENDENCIES),)
define LIBOPENVG_CONFIGURE_CMDS
echo "No libOpenVG implementation selected. Configuration error."
exit 1