summaryrefslogtreecommitdiffstats
path: root/package/opengl/libopenmax
diff options
context:
space:
mode:
authorSpenser Gilliland <spenser@gillilanding.com>2013-05-30 06:30:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-30 21:36:16 +0200
commit37f6ecd4d02d1e0fdce70fe4a7b404a6e2d06426 (patch)
tree9d34889fcbed8687dc11184781d13199ca31e3bc /package/opengl/libopenmax
parent1460245354019df29ffc4c3d76ddd61cb14dfd04 (diff)
downloadbuildroot-novena-37f6ecd4d02d1e0fdce70fe4a7b404a6e2d06426.tar.gz
buildroot-novena-37f6ecd4d02d1e0fdce70fe4a7b404a6e2d06426.zip
libopenmax: Add libopenmax virtual package
this adds the libopenmax virtual package for hardware based video acceleration [Peter: fix openmax-without-any-backends check] Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/opengl/libopenmax')
-rw-r--r--package/opengl/libopenmax/libopenmax.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/opengl/libopenmax/libopenmax.mk b/package/opengl/libopenmax/libopenmax.mk
new file mode 100644
index 000000000..430760208
--- /dev/null
+++ b/package/opengl/libopenmax/libopenmax.mk
@@ -0,0 +1,24 @@
+#############################################################
+#
+# Virtual package for libopenmax
+#
+#############################################################
+
+LIBOPENMAX_SOURCE =
+
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBOPENMAX_DEPENDENCIES += rpi-userland
+endif
+
+ifeq ($(BR2_PACKAGE_BELLAGIO),y)
+LIBOPENMAX_DEPENDENCIES += bellagio
+endif
+
+ifeq ($(LIBOPENMAX_DEPENDENCIES),)
+define LIBOPENMAX_CONFIGURE_CMDS
+ echo "No libopenmax implementation selected. Configuration error."
+ exit 1
+endef
+endif
+
+$(eval $(generic-package))