summaryrefslogtreecommitdiffstats
path: root/package/opencv/opencv-uclibc-optional-long-double-support.patch
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-07-16 23:37:30 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-17 11:12:54 +0200
commit0ff3d3d4710387fdf15ce8d129cda29eef16f8e3 (patch)
treeff107d469bb6679b79b557e51a6f54a8f4b9f3be /package/opencv/opencv-uclibc-optional-long-double-support.patch
parentcae0947b053bec39508c3c2e922ddcbd1f512225 (diff)
downloadbuildroot-novena-0ff3d3d4710387fdf15ce8d129cda29eef16f8e3.tar.gz
buildroot-novena-0ff3d3d4710387fdf15ce8d129cda29eef16f8e3.zip
opencv: bump to version 2.4.2
Update Config.in and .mk according to the new features. Remove the patch handling build with uclibc without long double support, which seems not necessary anymore. Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/opencv/opencv-uclibc-optional-long-double-support.patch')
-rw-r--r--package/opencv/opencv-uclibc-optional-long-double-support.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/package/opencv/opencv-uclibc-optional-long-double-support.patch b/package/opencv/opencv-uclibc-optional-long-double-support.patch
deleted file mode 100644
index b319849fb..000000000
--- a/package/opencv/opencv-uclibc-optional-long-double-support.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Upstream: https://code.ros.org/trac/opencv/ticket/1515
-
-[PATCH] Fix compile issue in flann module on uClibc without long double support
-
-uClibc configured without UCLIBC_HAS_LONG_DOUBLE_MATH (because of user
-choice or simply that the arch doesn't provide long doubles) doesn't
-provide fabsl(), breaking the build in the flann module.
-
-Work around it by not providing the long double template specialization.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- modules/flann/include/opencv2/flann/dist.h | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-Index: opencv-2.3.1a/modules/flann/include/opencv2/flann/dist.h
-===================================================================
---- opencv-2.3.1a.orig/modules/flann/include/opencv2/flann/dist.h
-+++ opencv-2.3.1a/modules/flann/include/opencv2/flann/dist.h
-@@ -40,6 +40,7 @@
- #else
- #include <stdint.h>
- #endif
-+#include <features.h>
-
- #include "defines.h"
-
-@@ -59,9 +60,11 @@
- template<>
- inline double abs<double>(double x) { return fabs(x); }
-
-+/* uClibc configured without long double math doesn't provide fabsl */
-+#if !(defined(__UCLIBC__) && !defined(__UCLIBC_HAS_LONG_DOUBLE_MATH__))
- template<>
- inline long double abs<long double>(long double x) { return fabsl(x); }
--
-+#endif
-
- template<typename T>
- struct Accumulator { typedef T Type; };