summaryrefslogtreecommitdiffstats
path: root/package/omap-u-boot-utils
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2012-05-17 10:11:30 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-19 22:31:35 +0200
commit761dc51bdb39963c0b99bb78ce9733762b42c5d7 (patch)
tree725ae04d466e85cf0b4eaeaf9b84e97447dce2b6 /package/omap-u-boot-utils
parent0b99b75fb66b453746179eee8e2a9131de87e331 (diff)
downloadbuildroot-novena-761dc51bdb39963c0b99bb78ce9733762b42c5d7.tar.gz
buildroot-novena-761dc51bdb39963c0b99bb78ce9733762b42c5d7.zip
omap-u-boot-utils: add new host package
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/omap-u-boot-utils')
-rw-r--r--package/omap-u-boot-utils/Config.in.host8
-rw-r--r--package/omap-u-boot-utils/omap-u-boot-utils.mk21
2 files changed, 29 insertions, 0 deletions
diff --git a/package/omap-u-boot-utils/Config.in.host b/package/omap-u-boot-utils/Config.in.host
new file mode 100644
index 000000000..63fbdf521
--- /dev/null
+++ b/package/omap-u-boot-utils/Config.in.host
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HOST_OMAP_U_BOOT_UTILS
+ bool "host omap-u-boot-utils"
+ help
+ U-Boot Utilities for Texas Instrument's OMAP platforms.
+ This is a set of tools to control U-Boot from scripts, generate
+ OMAP-specific signed image files and more.
+
+ https://github.com/nmenon/omap-u-boot-utils
diff --git a/package/omap-u-boot-utils/omap-u-boot-utils.mk b/package/omap-u-boot-utils/omap-u-boot-utils.mk
new file mode 100644
index 000000000..e2da9a1bf
--- /dev/null
+++ b/package/omap-u-boot-utils/omap-u-boot-utils.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# omap-u-boot-utils
+#
+#############################################################
+
+OMAP_U_BOOT_UTILS_VERSION = 8aff852322
+OMAP_U_BOOT_UTILS_SITE = http://github.com/nmenon/omap-u-boot-utils.git
+OMAP_U_BOOT_UTILS_SITE_METHOD = git
+
+define HOST_OMAP_U_BOOT_UTILS_BUILD_CMDS
+ $(MAKE) -C $(@D)
+endef
+
+define HOST_OMAP_U_BOOT_UTILS_INSTALL_CMDS
+ for f in gpsign pserial tagger ucmd ukermit ; do \
+ install -m 755 -D $(@D)/$$f $(HOST_DIR)/usr/bin/$$f ; \
+ done
+endef
+
+$(eval $(call GENTARGETS,host))