summaryrefslogtreecommitdiffstats
path: root/package/olsr
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-02-18 14:17:34 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-18 14:17:34 +0100
commita1c787ea6a7428fdfe88fd6c2333f35da5cec44d (patch)
tree52bb888146504bc5fe78fc7a5453b4a2df3e1263 /package/olsr
parent76081846730b541a2bab8e95fb79160a68801fba (diff)
downloadbuildroot-novena-a1c787ea6a7428fdfe88fd6c2333f35da5cec44d.tar.gz
buildroot-novena-a1c787ea6a7428fdfe88fd6c2333f35da5cec44d.zip
olsr: fix build
Pass TARGET_CONFIGURE_OPTS in the environment rather than as make arguments, so the olsr build system can append to CFLAGS / LDFLAGS - Otherwise build fails when the wrong linker flags are used to create the plugin .so's. Also pass ARCH, so the olsr build system choses the right libdir / PIC settings for the target, rather than for the host. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/olsr')
-rw-r--r--package/olsr/olsr.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/olsr/olsr.mk b/package/olsr/olsr.mk
index 75d5d66ab..03a8a02a0 100644
--- a/package/olsr/olsr.mk
+++ b/package/olsr/olsr.mk
@@ -16,7 +16,7 @@ OLSR_PLUGINS=dot_draw dyn_gw secure
OLSR_TARGET_PLUGIN=usr/lib/
define OLSR_BUILD_CMDS
- $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) olsrd $(OLSR_PLUGINS)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) ARCH=$(KERNEL_ARCH) -C $(@D) olsrd $(OLSR_PLUGINS)
endef
define OLSR_INSTALL_TARGET_CMDS