summaryrefslogtreecommitdiffstats
path: root/package/olsr/olsr.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-29 11:20:04 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-29 22:46:43 +0100
commit9b48690efb592ae17c9dd5a7db7b5ecebed09100 (patch)
tree96994df1d59a5342107cfb632928be22d81cdaae /package/olsr/olsr.mk
parent3c80d680f2e4d3e568bfeef2c46ceccc952db42d (diff)
downloadbuildroot-novena-9b48690efb592ae17c9dd5a7db7b5ecebed09100.tar.gz
buildroot-novena-9b48690efb592ae17c9dd5a7db7b5ecebed09100.zip
olsr: bump to version 0.6.4
Bump olsrd to version 0.6.4 Fixes: http://autobuild.buildroot.net/results/553c8157cd83ca60475caacc119779c778806781/ which is due to the old version not being friendly with newer flex versions. Enabled more plugins to make it more useful. Switch to forked mode in the init script to avoid console noise. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/olsr/olsr.mk')
-rw-r--r--package/olsr/olsr.mk18
1 files changed, 12 insertions, 6 deletions
diff --git a/package/olsr/olsr.mk b/package/olsr/olsr.mk
index be1ae1e4b..97088f33b 100644
--- a/package/olsr/olsr.mk
+++ b/package/olsr/olsr.mk
@@ -4,13 +4,17 @@
#
#############################################################
-OLSR_VERSION_MAJOR = 0.5
-OLSR_VERSION_MINOR = 6
+OLSR_VERSION_MAJOR = 0.6
+OLSR_VERSION_MINOR = 4
OLSR_VERSION = $(OLSR_VERSION_MAJOR).$(OLSR_VERSION_MINOR)
OLSR_SOURCE = olsrd-$(OLSR_VERSION).tar.bz2
OLSR_SITE = http://www.olsr.org/releases/$(OLSR_VERSION_MAJOR)
-#OLSR_PLUGINS=httpinfo tas dot_draw nameservice dyn_gw dyn_gw_plain pgraph bmf quagga secure
-OLSR_PLUGINS = dot_draw dyn_gw secure
+OLSR_PLUGINS = arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo jsoninfo \
+ mdns nameservice p2pd pgraph secure txtinfo watchdog
+# Doesn't really need quagga but not very useful without it
+OLSR_PLUGINS += $(if $(BR2_PACKAGE_QUAGGA),quagga)
+OLSR_LICENSE = BSD-3c LGPLv2.1+
+OLSR_LICENSE_FILES = license.txt lib/pud/nmealib/LICENSE
define OLSR_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) ARCH=$(KERNEL_ARCH) -C $(@D) olsrd
@@ -20,10 +24,12 @@ define OLSR_BUILD_CMDS
endef
define OLSR_INSTALL_TARGET_CMDS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install_bin
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) \
+ prefix="/usr" install_bin
for p in $(OLSR_PLUGINS) ; do \
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)/lib/$$p \
- LDCONFIG=/bin/true DESTDIR=$(TARGET_DIR) install ; \
+ LDCONFIG=/bin/true DESTDIR=$(TARGET_DIR) \
+ prefix="/usr" install ; \
done
$(INSTALL) -D -m 0755 package/olsr/S50olsr $(TARGET_DIR)/etc/init.d/S50olsr
test -r $(TARGET_DIR)/etc/olsrd.conf || \