summaryrefslogtreecommitdiffstats
path: root/package/olsr/olsr-configurable-ldconfig.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-27 05:35:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-27 17:22:35 +0100
commit7f8fa1afeb72a89eac9508fcae1ea6e3a42b10ed (patch)
tree38d37fe78ceb1fd43424202f61c1819243397475 /package/olsr/olsr-configurable-ldconfig.patch
parentf99c2a82fa1a2aa94072a5d2066828fd589075f8 (diff)
downloadbuildroot-novena-7f8fa1afeb72a89eac9508fcae1ea6e3a42b10ed.tar.gz
buildroot-novena-7f8fa1afeb72a89eac9508fcae1ea6e3a42b10ed.zip
olsr: rework build and install procedure
This commit reworks the build and install steps of the olsr package, to fix a number of problems and do minor improvements: 1. The build step was doing "make <foo>" for each plugin. Unfortunately, inside olsr build system, doing "make <foo>" for a plugin triggers a clean of the plugin directory, a build, and then an installation of the plugin. This installation fails because DESTDIR is not passed at the install step. This leads to build issues like http://autobuild.buildroot.org/results/a9fed78cd0b3991763a797c38387edd4157fbdb9/build-end.log. To fix this, we call make in each plugin's directory, which is what "make <foo>" was doing internally. 2. The install step was manually installing the olsrd binary. We now instead use the install_bin make target that comes in olsr's build system. 3. The install step was manually installing the olsr plugins. We now instead use the install make target available in each plugin's makefile. 4. We use 'install' to install the init script, which avoids the manual creation of /etc/init.d. 5. We use 'install' to install the sample configuration file. 6. We remove the useless strip commands. 7. We add a patch that allows us to pass LDCONFIG=/bin/true to avoid ldconfig being called during the installation process. 8. We remove commands from the clean step that were in fact uninstallation commands. We don't bother re-adding those commands in an uninstallation step, since it is now generally accepted that the uninstall step is quite useless and should be deprecated. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/olsr/olsr-configurable-ldconfig.patch')
-rw-r--r--package/olsr/olsr-configurable-ldconfig.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/olsr/olsr-configurable-ldconfig.patch b/package/olsr/olsr-configurable-ldconfig.patch
new file mode 100644
index 000000000..09e34f137
--- /dev/null
+++ b/package/olsr/olsr-configurable-ldconfig.patch
@@ -0,0 +1,30 @@
+Make ldconfig configurable
+
+In a cross-compilation set up, running /sbin/ldconfig is useless, so
+we make the path to ldconfig configurable through the environment/make
+command line. This allows to pass LDCONFIG=/bin/true when doing
+cross-compilation.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/make/Makefile.linux
+===================================================================
+--- a/make/Makefile.linux
++++ b/make/Makefile.linux
+@@ -3,6 +3,7 @@
+ #
+
+ ARCH := $(shell uname -m)
++LDCONFIG ?= /sbin/ldconfig
+ DESTDIR ?=
+ LIBDIR = $(DESTDIR)$(shell if [ "$(ARCH)" = "x86_64" -a -d "/usr/lib64" ]; then echo "/usr/lib64"; else echo "/usr/lib"; fi)
+
+@@ -14,7 +15,7 @@
+
+ PLUGIN_FULLNAME ?= $(PLUGIN_NAME).so.$(PLUGIN_VER)
+ INSTALL_LIB = install -D -m 755 $(PLUGIN_FULLNAME) $(LIBDIR)/$(PLUGIN_FULLNAME); \
+- /sbin/ldconfig -n $(LIBDIR)
++ $(LDCONFIG) -n $(LIBDIR)
+
+ ifdef OLSRD_PLUGIN
+ GENERATE_PIC = true