summaryrefslogtreecommitdiffstats
path: root/package/nuttcp
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2010-10-08 12:26:20 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-05 16:53:09 +0100
commit6097b191d3bfae34c27c077c369869e4b49ff76f (patch)
treeab87e036f628d3182aeb1f0a170ddaf71333bb83 /package/nuttcp
parent3ad0fac1b06833aa238afd555f38146cbda31a4d (diff)
downloadbuildroot-novena-6097b191d3bfae34c27c077c369869e4b49ff76f.tar.gz
buildroot-novena-6097b191d3bfae34c27c077c369869e4b49ff76f.zip
New package: nuttcp
Add a new TCP/UDP network testing tool, that provides some advanced features compared to ttcp. [Peter: cleanup, fix FLAGS, move to network] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/nuttcp')
-rw-r--r--package/nuttcp/Config.in6
-rw-r--r--package/nuttcp/nuttcp.mk25
2 files changed, 31 insertions, 0 deletions
diff --git a/package/nuttcp/Config.in b/package/nuttcp/Config.in
new file mode 100644
index 000000000..fb6d3b186
--- /dev/null
+++ b/package/nuttcp/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_NUTTCP
+ bool "nuttcp"
+ help
+ nuttcp is a TCP/UDP network testing tool, much like iperf
+
+ http://www.lcp.nrl.navy.mil/nuttcp/nuttcp.html
diff --git a/package/nuttcp/nuttcp.mk b/package/nuttcp/nuttcp.mk
new file mode 100644
index 000000000..e3867ea42
--- /dev/null
+++ b/package/nuttcp/nuttcp.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# nuttcp
+#
+#############################################################
+
+NUTTCP_VERSION = 6.1.2
+NUTTCP_SITE = http://www.lcp.nrl.navy.mil/nuttcp/
+NUTTCP_SOURCE = nuttcp-$(NUTTCP_VERSION).tar.bz2
+
+define NUTTCP_BUILD_CMDS
+ $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+ -C $(@D) all
+endef
+
+define NUTTCP_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/nuttcp-$(NUTTCP_VERSION) \
+ $(TARGET_DIR)/usr/bin/nuttcp
+endef
+
+define NUTTCP_UNINSTALL_TARGET_CMDS
+ rm -f $(TARGET_DIR)/usr/bin/nuttcp
+endef
+
+$(eval $(call GENTARGETS,package,nuttcp))