summaryrefslogtreecommitdiffstats
path: root/package/numactl
diff options
context:
space:
mode:
authorWill Newton <will.newton@imgtec.com>2013-05-26 12:08:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-27 10:41:16 +0200
commitb05e74ff92b6728369e1540fc0a2bd60025f2146 (patch)
treeda5012f63ed82d12efaabfe2349a52f75b6332aa /package/numactl
parent6c183aed401f7228ba6667e170c0642d86706e0f (diff)
downloadbuildroot-novena-b05e74ff92b6728369e1540fc0a2bd60025f2146.tar.gz
buildroot-novena-b05e74ff92b6728369e1540fc0a2bd60025f2146.zip
numactl: new package
[Thomas: updated to 2.0.8, restricted to supported architectures, added licensing informations, updated to latest Buildroot package infrastructure] [Peter: Fix LICENSE_FILES typo, needs largefile support in toolchain] Signed-off-by: Will Newton <will.newton@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/numactl')
-rw-r--r--package/numactl/Config.in16
-rw-r--r--package/numactl/numactl.mk21
2 files changed, 37 insertions, 0 deletions
diff --git a/package/numactl/Config.in b/package/numactl/Config.in
new file mode 100644
index 000000000..21e76fb99
--- /dev/null
+++ b/package/numactl/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_NUMACTL
+ bool "numactl"
+ # numactl uses some system calls that are not available on all
+ # architectures.
+ depends on BR2_LARGEFILE
+ depends on BR2_i386 || BR2_mips || BR2_mipsel || \
+ BR2_mips64 || BR2_mips64el || BR2_powerpc || BR2_x86_64
+ help
+ numactl allows you to run your application on specific cpus
+ and memory nodes. It does this by supplying a NUMA memory
+ policy to the operating system before running your program.
+
+ http://oss.sgi.com/projects/libnuma/
+
+comment "numactl requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/numactl/numactl.mk b/package/numactl/numactl.mk
new file mode 100644
index 000000000..fe6f23f74
--- /dev/null
+++ b/package/numactl/numactl.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# numactl
+#
+#############################################################
+
+NUMACTL_VERSION = 2.0.8
+NUMACTL_SOURCE = numactl-$(NUMACTL_VERSION).tar.gz
+NUMACTL_SITE = ftp://oss.sgi.com/www/projects/libnuma/download/
+NUMACTL_LICENSE = LGPLv2.1 (libnuma), GPLv2 (programs)
+NUMACTL_LICENSE_FILES = README
+
+define NUMACTL_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define NUMACTL_INSTALL_TARGET_CMDS
+ $(MAKE) prefix=$(TARGET_DIR) libdir=$(TARGET_DIR)/lib -C $(@D) install
+endef
+
+$(eval $(generic-package))