summaryrefslogtreecommitdiffstats
path: root/package/ntp
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/ntp
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
downloadbuildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.tar.gz
buildroot-novena-73f7be82904f487d167493e76b415fbe5b5f8c5a.zip
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/ntp')
-rw-r--r--package/ntp/ntp.mk62
1 files changed, 62 insertions, 0 deletions
diff --git a/package/ntp/ntp.mk b/package/ntp/ntp.mk
new file mode 100644
index 000000000..b3f840a3e
--- /dev/null
+++ b/package/ntp/ntp.mk
@@ -0,0 +1,62 @@
+#############################################################
+#
+# ntp
+#
+#############################################################
+NTP_SOURCE:=ntp-4.1.2.tar.gz
+NTP_SITE:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4
+NTP_DIR:=$(BUILD_DIR)/ntp-4.1.2
+NTP_CAT:=zcat
+NTP_BINARY:=ntpdate/ntpdate
+NTP_TARGET_BINARY:=usr/bin/ntpdate
+
+
+$(DL_DIR)/$(NTP_SOURCE):
+ $(WGET) -P $(DL_DIR) $(NTP_SITE)/$(NTP_SOURCE)
+
+ntp-source: $(DL_DIR)/$(NTP_SOURCE)
+
+$(NTP_DIR)/.unpacked: $(DL_DIR)/$(NTP_SOURCE)
+ $(NTP_CAT) $(DL_DIR)/$(NTP_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ $(SED) "s,^#if.*__GLIBC__.*_BSD_SOURCE.*$$,#if 0," \
+ $(NTP_DIR)/ntpd/refclock_pcf.c;
+ touch $(NTP_DIR)/.unpacked
+
+$(NTP_DIR)/.configured: $(NTP_DIR)/.unpacked
+ (cd $(NTP_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $(DISABLE_NLS) \
+ --with-shared \
+ --program-transform-name=s,,, \
+ );
+ touch $(NTP_DIR)/.configured
+
+$(NTP_DIR)/$(NTP_BINARY): $(NTP_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(NTP_DIR)
+
+$(TARGET_DIR)/$(NTP_TARGET_BINARY): $(NTP_DIR)/$(NTP_BINARY)
+ install -m 755 $(NTP_DIR)/$(NTP_BINARY) $(TARGET_DIR)/$(NTP_TARGET_BINARY)
+
+ntp: uclibc $(TARGET_DIR)/$(NTP_TARGET_BINARY)
+
+ntp-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(NTP_DIR) uninstall
+ -$(MAKE) -C $(NTP_DIR) clean
+
+ntp-dirclean:
+ rm -rf $(NTP_DIR)
+