summaryrefslogtreecommitdiffstats
path: root/package/ntfs-3g
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-18 09:32:10 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-28 16:11:40 +0200
commitfb97591e228b19f40c840f99893830b2dd022ab5 (patch)
tree32ec8a9b7fb8b27ff6e4dac08665a85226d5f36c /package/ntfs-3g
parentdb697f96b77199c015f57a9fdfd5dd7f0374b8bb (diff)
downloadbuildroot-novena-fb97591e228b19f40c840f99893830b2dd022ab5.tar.gz
buildroot-novena-fb97591e228b19f40c840f99893830b2dd022ab5.zip
ntfs-3g: bump to version 2011.4.12 and enhance
ntfsprogs is now included into ntfs-3g so add an option to enable/disable it. It probably doesn't make sense to build ntfsprogs alone so it's not implemented. Add the encrypted volume support option now that we've got gnutls. Also add support for libuuid if it's present. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ntfs-3g')
-rw-r--r--package/ntfs-3g/Config.in15
-rw-r--r--package/ntfs-3g/ntfs-3g.mk23
2 files changed, 36 insertions, 2 deletions
diff --git a/package/ntfs-3g/Config.in b/package/ntfs-3g/Config.in
index 865f9b41f..530103889 100644
--- a/package/ntfs-3g/Config.in
+++ b/package/ntfs-3g/Config.in
@@ -12,5 +12,20 @@ config BR2_PACKAGE_NTFS_3G
http://www.ntfs-3g.org/
+if BR2_PACKAGE_NTFS_3G
+
+config BR2_PACKAGE_NTFS_3G_ENCRYPTED
+ bool "encrypted volumes"
+ select BR2_PACKAGE_GNUTLS
+ help
+ Enable support for NTFS encrypted volumes.
+
+config BR2_PACKAGE_NTFS_3G_NTFSPROGS
+ bool "ntfsprogs"
+ help
+ Install NTFS utilities.
+
+endif
+
comment "ntfs-3g requires a toolchain with LARGEFILE and WCHAR support"
depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
diff --git a/package/ntfs-3g/ntfs-3g.mk b/package/ntfs-3g/ntfs-3g.mk
index 99fc20cb3..f6462bb0b 100644
--- a/package/ntfs-3g/ntfs-3g.mk
+++ b/package/ntfs-3g/ntfs-3g.mk
@@ -4,10 +4,29 @@
#
#############################################################
-NTFS_3G_VERSION = 2010.10.2
-NTFS_3G_SOURCE = ntfs-3g-$(NTFS_3G_VERSION).tgz
+NTFS_3G_VERSION = 2011.4.12
+NTFS_3G_SOURCE = ntfs-3g_ntfsprogs-$(NTFS_3G_VERSION).tgz
NTFS_3G_SITE = http://tuxera.com/opensource
NTFS_3G_CONF_OPT = --disable-ldconfig
NTFS_3G_INSTALL_STAGING = YES
+NTFS_3G_DEPENDENCIES = host-pkg-config
+
+ifeq ($(BR2_PACKAGE_LIBFUSE),y)
+ NTFS_3G_CONF_OPT += --with-fuse=external
+ NTFS_3G_DEPENDENCIES += libfuse
+endif
+
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+ NTFS_3G_DEPENDENCIES += util-linux
+endif
+
+ifeq ($(BR2_PACKAGE_NTFS_3G_ENCRYPTED),y)
+ NTFS_3G_CONF_OPT += --enable-crypto
+ NTFS_3G_DEPENDENCIES += gnutls
+endif
+
+ifneq ($(BR2_PACKAGE_NTFS_3G_NTFSPROGS),y)
+ NTFS_3G_CONF_OPT += --disable-ntfsprogs
+endif
$(eval $(call AUTOTARGETS))