summaryrefslogtreecommitdiffstats
path: root/package/ntfs-3g
diff options
context:
space:
mode:
authorIvan Kuten <ivan.kuten@promwad.com>2007-11-24 16:09:25 +0000
committerIvan Kuten <ivan.kuten@promwad.com>2007-11-24 16:09:25 +0000
commite1498416ac16cda49d338795be3760884d476d1e (patch)
treec4b130bd56b074edecd6fd13822c5774f146b829 /package/ntfs-3g
parent4094140f52994e274ef04a5e1b0ae0068dcaad6a (diff)
downloadbuildroot-novena-e1498416ac16cda49d338795be3760884d476d1e.tar.gz
buildroot-novena-e1498416ac16cda49d338795be3760884d476d1e.zip
add fuse and nfs-3g packages
Diffstat (limited to 'package/ntfs-3g')
-rw-r--r--package/ntfs-3g/Config.in7
-rw-r--r--package/ntfs-3g/ntfs-3g.mk82
2 files changed, 89 insertions, 0 deletions
diff --git a/package/ntfs-3g/Config.in b/package/ntfs-3g/Config.in
new file mode 100644
index 000000000..5cf006ce4
--- /dev/null
+++ b/package/ntfs-3g/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_NTFS-3G
+ bool "ntfs-3g"
+ default n
+ help
+ The NTFS-3G driver is an open source, freely available read/write NTFS driver for Linux, FreeBSD, Mac OS X, NetBSD, and Haiku. It provides safe and fast handling of the Windows XP, Windows Server 2003, Windows 2000 and Windows Vista file systems. Most POSIX file system operations are supported, with the exception of full file ownership and access right support.
+
+ http://www.ntfs-3g.org/
diff --git a/package/ntfs-3g/ntfs-3g.mk b/package/ntfs-3g/ntfs-3g.mk
new file mode 100644
index 000000000..aa1435cff
--- /dev/null
+++ b/package/ntfs-3g/ntfs-3g.mk
@@ -0,0 +1,82 @@
+#############################################################
+#
+# ntfs-3g
+#
+#############################################################
+NTFS-3G_VERSION:=1.810
+NTFS-3G_SOURCE:=ntfs-3g-$(NTFS-3G_VERSION).tgz
+NTFS-3G_SITE:=www.ntfs-3g.org
+NTFS-3G_DIR:=$(BUILD_DIR)/ntfs-3g-$(NTFS-3G_VERSION)
+NTFS-3G_BINARY:=ntfs-3g
+
+
+$(DL_DIR)/$(NTFS-3G_SOURCE):
+ $(WGET) -P $(DL_DIR) $(NTFS-3G_SITE)/$(NTFS-3G_SOURCE)
+
+$(NTFS-3G_DIR)/.source: $(DL_DIR)/$(NTFS-3G_SOURCE)
+ $(ZCAT) $(DL_DIR)/$(NTFS-3G_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $@
+
+$(NTFS-3G_DIR)/.configured: $(NTFS-3G_DIR)/.source
+ (cd $(NTFS-3G_DIR); rm -rf config.cache ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/usr/include \
+ --program-prefix="" \
+ --with-gnu-ld \
+ --enable-shared \
+ --enable-static \
+ , \
+ ac_cv_path_LDCONFIG=""\
+ );
+ touch $@
+
+$(NTFS-3G_DIR)/.compiled: $(NTFS-3G_DIR)/.configured
+ $(MAKE) prefix=$/usr CC=$(TARGET_CC)-C $(NTFS-3G_DIR)
+ touch $@
+# CROSS_COMPILE="$(TARGET_CROSS)"
+
+
+
+$(STAGING_DIR)/usr/bin/ntfs-3g: $(NTFS-3G_DIR)/.compiled
+ $(MAKE) prefix=$/usr -C $(NTFS-3G_DIR) DESTDIR=$(STAGING_DIR)/ install
+ touch -c $@
+
+$(TARGET_DIR)/usr/bin/ntfs-3g: $(STAGING_DIR)/usr/bin/ntfs-3g
+ cp -dpf $(STAGING_DIR)/usr/lib/libntfs-3g.so.* $(TARGET_DIR)/usr/lib/
+ cp -dpf $(STAGING_DIR)/usr/bin/ntfs-3g $(TARGET_DIR)/usr/bin/
+ touch -c $@
+
+ntfs-3g: uclibc pkgconfig libfuse $(TARGET_DIR)/usr/bin/ntfs-3g
+
+ntfs-3g-source: $(DL_DIR)/$(NTFS-3G_SOURCE)
+
+ntfs-3g-clean:
+ $(MAKE) prefix=$(STAGING_DIR)/usr -C $(NTFS-3G_DIR) uninstall
+ rm -f $(TARGET_DIR)/usr/lib/libntfs-3g*
+ rm -f $(TARGET_DIR)/usr/bin/ntfs-3g
+ -$(MAKE) -C $(NTFS-3G_DIR) clean
+
+ntfs-3g-dirclean:
+ rm -rf $(NTFS-3G_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+#ifeq ($(strip $(BR2_PACKAGE_NTFS-3G)),y)
+TARGETS+=ntfs-3g
+#endif