summaryrefslogtreecommitdiffstats
path: root/package/netsnmp
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-05-02 12:36:05 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-02 17:44:30 +0200
commitd1b42b24b88cc15a825d20221b2199bce4f2e6aa (patch)
treec2a67ffb6984ff7773d1ef0d3aa3a9023318661c /package/netsnmp
parentd2b325c1f02f4579cbc7488a3321d313d7bd2239 (diff)
downloadbuildroot-novena-d1b42b24b88cc15a825d20221b2199bce4f2e6aa.tar.gz
buildroot-novena-d1b42b24b88cc15a825d20221b2199bce4f2e6aa.zip
net-snmp: fixup paths in net-snmp-config
Exposed by commit 7e3e8ec040b06d6e2fb69e55c004f1ebc02c76d0 net-snmp-config goes for -L/usr/lib thus things break since this wins over the sysroot if we have a host net-snmp library around when we build packages that link against net-snmp. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/netsnmp.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index edb1704f7..570432744 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -68,4 +68,14 @@ define NETSNMP_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/lib/libnetsnmp*
endef
+define NETSNMP_STAGING_NETSNMP_CONFIG_FIXUP
+ $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \
+ -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
+ -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include\',g" \
+ -e "s,^libdir=.*,libdir=\'$(STAGING_DIR)/usr/lib\',g" \
+ $(STAGING_DIR)/usr/bin/net-snmp-config
+endef
+
+NETSNMP_POST_INSTALL_STAGING_HOOKS += NETSNMP_STAGING_NETSNMP_CONFIG_FIXUP
+
$(eval $(call AUTOTARGETS,package,netsnmp))