summaryrefslogtreecommitdiffstats
path: root/package/netsnmp
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/netsnmp
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
downloadbuildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.tar.gz
buildroot-novena-44eedc5c44416a97b3f5ca03d596ec3c9fb29380.zip
facelift step number two
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/netsnmp.mk3
-rw-r--r--package/netsnmp/netsnmp.patch32
2 files changed, 33 insertions, 2 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index eeb244967..04f0749e0 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -9,7 +9,6 @@ NETSNMP_DIR:=$(BUILD_DIR)/net-snmp-5.1
NETSNMP_SOURCE:=net-snmp-5.1.tar.gz
NETSNMP_PATCH1:=net-snmp_5.1-5.diff.gz
NETSNMP_PATCH1_URL:=http://ftp.debian.org/debian/pool/main/n/net-snmp/
-NETSNMP_PATCH2:=$(SOURCE_DIR)/netsnmp.patch
$(DL_DIR)/$(NETSNMP_SOURCE):
$(WGET) -P $(DL_DIR) $(NETSNMP_URL)/$(NETSNMP_SOURCE)
@@ -20,7 +19,7 @@ $(DL_DIR)/$(NETSNMP_PATCH1):
$(NETSNMP_DIR)/.unpacked: $(DL_DIR)/$(NETSNMP_SOURCE) $(DL_DIR)/$(NETSNMP_PATCH1)
zcat $(DL_DIR)/$(NETSNMP_SOURCE) | tar -C $(BUILD_DIR) -xvf -
zcat $(DL_DIR)/$(NETSNMP_PATCH1) | patch -p1 -d $(NETSNMP_DIR)
- cat $(NETSNMP_PATCH2) | patch -p1 -d $(NETSNMP_DIR)
+ toolchain/patch-kernel.sh $(NETSNMP_DIR) package/netsnmp/ netsnmp\*.patch
touch $(NETSNMP_DIR)/.unpacked
# We set CAN_USE_SYSCTL to no and use /proc since the
diff --git a/package/netsnmp/netsnmp.patch b/package/netsnmp/netsnmp.patch
new file mode 100644
index 000000000..076592bd8
--- /dev/null
+++ b/package/netsnmp/netsnmp.patch
@@ -0,0 +1,32 @@
+diff -urN net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c net-snmp-5.1/agent/mibgroup/host/hr_system.c
+--- net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c 2003-02-28 22:35:13.000000000 -0600
++++ net-snmp-5.1/agent/mibgroup/host/hr_system.c 2004-03-31 22:06:05.000000000 -0600
+@@ -286,7 +286,11 @@
+ current user */
+ if (kill(utmp_p->ut_pid, 0) == -1 && errno == ESRCH) {
+ utmp_p->ut_type = DEAD_PROCESS;
++#if HAVE_UTMPX_H
+ pututxline(utmp_p);
++#else
++ pututline(utmp_p);
++#endif
+ continue;
+ }
+ ++total;
+diff -urN net-snmp-5.1-dist/configure.in net-snmp-5.1/configure.in
+--- net-snmp-5.1-dist/configure.in 2004-03-31 21:59:14.000000000 -0600
++++ net-snmp-5.1/configure.in 2004-03-31 22:06:05.000000000 -0600
+@@ -1865,13 +1865,8 @@
+ if test $cross_compiling = yes; then
+ if test $with_endianness = "big"; then
+ AC_DEFINE(WORDS_BIGENDIAN)
+- elif test -z $with_endianness; then
+- AC_MSG_ERROR([You are cross-compiling, but you have not specified the target's endianness])
+ fi
+ else
+- if test $with_endianness; then
+- AC_MSG_ERROR([Endianness has been specified, but you are not cross-compiling.])
+- fi
+ AC_C_BIGENDIAN
+ fi
+