summaryrefslogtreecommitdiffstats
path: root/package/netsnmp
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-20 11:12:50 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-20 11:12:50 +0000
commit20b3086e5f1e2d7e6621f0eb361d206eb5e4ae36 (patch)
treed34d6d9a2447d5b02b3afe275b9303316ef7712d /package/netsnmp
parentd3f3d1c7ad16a15c397e124dde0b09853f47d1bf (diff)
downloadbuildroot-novena-20b3086e5f1e2d7e6621f0eb361d206eb5e4ae36.tar.gz
buildroot-novena-20b3086e5f1e2d7e6621f0eb361d206eb5e4ae36.zip
- pass the correct endian
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/netsnmp.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index 09184c7b0..34b28cbe3 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -22,6 +22,12 @@ $(NETSNMP_DIR)/.unpacked: $(DL_DIR)/$(NETSNMP_SOURCE) $(DL_DIR)/$(NETSNMP_PATCH1
toolchain/patch-kernel.sh $(NETSNMP_DIR) package/netsnmp/ netsnmp\*.patch
touch $(NETSNMP_DIR)/.unpacked
+ifeq ($(BR2_ENDIAN),"BIG")
+NETSNMP_ENDIAN=big
+else
+NETSNMP_ENDIAN=little
+endif
+
# We set CAN_USE_SYSCTL to no and use /proc since the
# sysctl code in this thing is apparently intended for
# freebsd or some such thing...
@@ -37,7 +43,7 @@ $(NETSNMP_DIR)/.configured: $(NETSNMP_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --with-endianness=little \
+ --with-endianness=$(NETSNMP_ENDIAN) \
--with-persistent-directory=/var/lib/snmp \
--enable-ucd-snmp-compatibility \
--enable-shared \