summaryrefslogtreecommitdiffstats
path: root/package/netperf
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-02-18 12:49:27 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-03-25 11:54:22 +0100
commited91e786e674122163620c2d15e7a000b6427af5 (patch)
treed61d7e896b4b1f6bf806e30f6e828f0677184be9 /package/netperf
parent4f0361ab2ca4f25207c84b557e31319c9a417a76 (diff)
downloadbuildroot-novena-ed91e786e674122163620c2d15e7a000b6427af5.tar.gz
buildroot-novena-ed91e786e674122163620c2d15e7a000b6427af5.zip
Add new netperf package
Closes #1105 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/netperf')
-rw-r--r--package/netperf/Config.in6
-rw-r--r--package/netperf/netperf.mk25
2 files changed, 31 insertions, 0 deletions
diff --git a/package/netperf/Config.in b/package/netperf/Config.in
new file mode 100644
index 000000000..2f36b1b0d
--- /dev/null
+++ b/package/netperf/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_NETPERF
+ bool "netperf"
+ help
+ Network performance benchmark tool
+
+ http://www.netperf.org/
diff --git a/package/netperf/netperf.mk b/package/netperf/netperf.mk
new file mode 100644
index 000000000..d198eee52
--- /dev/null
+++ b/package/netperf/netperf.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# netperf
+#
+#############################################################
+
+NETPERF_VERSION = 2.4.5
+NETPERF_SITE = ftp://ftp.netperf.org/netperf
+NETPERF_CONF_ENV = ac_cv_func_setpgrp_void=set
+
+$(eval $(call AUTOTARGETS,package,netperf))
+
+$(NETPERF_TARGET_INSTALL_TARGET):
+ $(call MESSAGE,"Installing to target")
+ $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netperf \
+ $(TARGET_DIR)/usr/bin/netperf
+ $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netserver \
+ $(TARGET_DIR)/usr/bin/netserver
+ touch $@
+
+$(NETPERF_TARGET_UNINSTALL):
+ $(call MESSAGE,"Uninstalling")
+ rm -f $(TARGET_DIR)/usr/bin/netperf
+ rm -f $(TARGET_DIR)/usr/bin/netserver
+ rm -f $(NETPERF_TARGET_INSTALL_TARGET) $(NETPERF_HOOK_POST_INSTALL)