summaryrefslogtreecommitdiffstats
path: root/package/netperf
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 23:25:02 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-12 19:26:51 +0200
commitb88c394685f3c77219da743d6e0c434312712cf4 (patch)
treee863acebdf4ce62b8ff9eb3cc4a7e9f3afcac2e2 /package/netperf
parent7d6e7bcc26d84846838a493d3c10e254ae824552 (diff)
downloadbuildroot-novena-b88c394685f3c77219da743d6e0c434312712cf4.tar.gz
buildroot-novena-b88c394685f3c77219da743d6e0c434312712cf4.zip
netperf: use correct step override method
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/netperf')
-rw-r--r--package/netperf/netperf.mk18
1 files changed, 8 insertions, 10 deletions
diff --git a/package/netperf/netperf.mk b/package/netperf/netperf.mk
index d198eee52..6bf9b5c17 100644
--- a/package/netperf/netperf.mk
+++ b/package/netperf/netperf.mk
@@ -8,18 +8,16 @@ NETPERF_VERSION = 2.4.5
NETPERF_SITE = ftp://ftp.netperf.org/netperf
NETPERF_CONF_ENV = ac_cv_func_setpgrp_void=set
-$(eval $(call AUTOTARGETS,package,netperf))
-
-$(NETPERF_TARGET_INSTALL_TARGET):
- $(call MESSAGE,"Installing to target")
- $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netperf \
+define NETPERF_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 $(@D)/src/netperf \
$(TARGET_DIR)/usr/bin/netperf
- $(INSTALL) -m 0755 $(NETPERF_DIR)/src/netserver \
+ $(INSTALL) -m 0755 $(@D)/src/netserver \
$(TARGET_DIR)/usr/bin/netserver
- touch $@
+endef
-$(NETPERF_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define NETPERF_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/netperf
rm -f $(TARGET_DIR)/usr/bin/netserver
- rm -f $(NETPERF_TARGET_INSTALL_TARGET) $(NETPERF_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,netperf))