summaryrefslogtreecommitdiffstats
path: root/package/netkittelnet/netkittelnet.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-10-09 09:36:35 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-09 09:36:35 +0200
commiteaef48367e24724da6533b3b78978cf9f0da19d7 (patch)
tree420fa30a6f1d4ea74cdf3a37fe15af604ac1a216 /package/netkittelnet/netkittelnet.mk
parentd3501735f64414eea0e29d59aaa6f2f8ce5395eb (diff)
downloadbuildroot-novena-eaef48367e24724da6533b3b78978cf9f0da19d7.tar.gz
buildroot-novena-eaef48367e24724da6533b3b78978cf9f0da19d7.zip
netkittelnet: fix build on toolchains without C++ support
The configure script checks for C++ support as telnet (but not telnetd) contains C++ code. This used to work by accident if the host had g++, as we didn't pass TARGET_CONFIGURE_OPTS to configure (which sets CXX to /bin/false). Fix it by removing the g++ check and rewriting the configure checks to use the C compiler instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/netkittelnet/netkittelnet.mk')
-rw-r--r--package/netkittelnet/netkittelnet.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/netkittelnet/netkittelnet.mk b/package/netkittelnet/netkittelnet.mk
index 7bcfaf8c3..a0f278601 100644
--- a/package/netkittelnet/netkittelnet.mk
+++ b/package/netkittelnet/netkittelnet.mk
@@ -14,6 +14,8 @@ define NETKITTELNET_CONFIGURE_CMDS
$(SED) "s/main()/main(void)/;" $(@D)/configure
# Disable termcap support
$(SED) "s~\(.*termcap\.h.*\)~/* \1 */~;" $(@D)/telnetd/telnetd.c
+ # C++ support not needed for telnetd
+ $(SED) 's/CXX/CC/g' -e 's/conftest.cc/conftest.c/g' $(@D)/configure
(cd $(@D); \
$(TARGET_CONFIGURE_OPTS) \
./configure \