summaryrefslogtreecommitdiffstats
path: root/package/neon
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-08-26 20:47:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-08-26 20:47:12 +0000
commit95313e2000338221b035e20a4d7376cde394f4eb (patch)
tree77fe8c082ff4fdbee50adbbff479ed0ddd7727ef /package/neon
parent3e1ed2feb00d3b4901d971d5cfbf7996a47ea36c (diff)
downloadbuildroot-novena-95313e2000338221b035e20a4d7376cde394f4eb.tar.gz
buildroot-novena-95313e2000338221b035e20a4d7376cde394f4eb.zip
neon: fix compilation without xml support
webdav needs xml support, so disable it if no xml support is selected, otherwise configure could get confused about a host xml2-config script.
Diffstat (limited to 'package/neon')
-rw-r--r--package/neon/neon.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 6eba627cd..750217acc 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -21,5 +21,9 @@ NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
NEON_CONF_OPT+=--with-libxml2=no
NEON_DEPENDENCIES+=expat
endif
+ifeq ($(strip $(BR2_PACKAGE_NEON_NOXML)),y)
+# webdav needs xml support
+NEON_CONF_OPT+=--disable-webdav
+endif
$(eval $(call AUTOTARGETS,package,neon))