summaryrefslogtreecommitdiffstats
path: root/package/neon
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-10-11 09:23:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-11 09:27:25 +0200
commit66e09abc57f88bfea7bebd50b9dff7d56e99689e (patch)
treea33fffb649cc4b82dbc7af25c03a5decee3d1a12 /package/neon
parent8ece8e2775cb189874a0e490934cea2f39dbb734 (diff)
downloadbuildroot-novena-66e09abc57f88bfea7bebd50b9dff7d56e99689e.tar.gz
buildroot-novena-66e09abc57f88bfea7bebd50b9dff7d56e99689e.zip
neon: cleanup
Whitespace fixes / removal of redundant lines. No functional change. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/neon')
-rw-r--r--package/neon/neon.mk55
1 files changed, 27 insertions, 28 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 95664d7dc..272d5e084 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -3,46 +3,45 @@
# neon
#
#############################################################
-NEON_VERSION:=0.29.6
-NEON_SITE:=http://www.webdav.org/neon/
-NEON_INSTALL_STAGING:=YES
-NEON_CONF_OPT:=--without-gssapi --disable-rpath
+NEON_VERSION= 0.29.6
+NEON_SITE = http://www.webdav.org/neon/
+NEON_INSTALL_STAGING = YES
+NEON_CONF_OPT = --without-gssapi --disable-rpath
-NEON_DEPENDENCIES:=host-pkg-config
+NEON_DEPENDENCIES = host-pkg-config
-ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
-NEON_CONF_OPT+=--with-libxml2=yes
-NEON_CONF_OPT+=--with-expat=no
-NEON_CONF_ENV+=ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
-NEON_DEPENDENCIES+=libxml2
-endif
ifeq ($(BR2_PACKAGE_NEON_ZLIB),y)
-NEON_CONF_OPT+=--with-zlib=$(STAGING_DIR)
-NEON_DEPENDENCIES+=zlib
+NEON_CONF_OPT += --with-zlib=$(STAGING_DIR)
+NEON_DEPENDENCIES += zlib
else
-NEON_CONF_OPT+=--without-zlib
+NEON_CONF_OPT += --without-zlib
endif
+
ifeq ($(BR2_PACKAGE_NEON_SSL),y)
-NEON_CONF_OPT+=--with-ssl
-NEON_DEPENDENCIES+=openssl
+NEON_CONF_OPT += --with-ssl
+NEON_DEPENDENCIES += openssl
else
-NEON_CONF_OPT+=--without-ssl
+NEON_CONF_OPT += --without-ssl
endif
+
ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
-NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
-NEON_CONF_OPT+=--with-libxml2=no
-NEON_DEPENDENCIES+=expat
-endif
-ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
-# webdav needs xml support
-NEON_CONF_OPT+=--disable-webdav
+NEON_CONF_OPT += --with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_DEPENDENCIES += expat
+else
+NEON_CONF_OPT += --with-expat=no
endif
-ifeq ($(BR2_PACKAGE_OPENSSL),y)
-NEON_CONF_OPT+=--with-ssl
-NEON_DEPENDENCIES+=openssl
+ifeq ($(BR2_PACKAGE_NEON_LIBXML2),y)
+NEON_CONF_OPT += --with-libxml2=yes
+NEON_CONF_ENV += ac_cv_prog_XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
+NEON_DEPENDENCIES += libxml2
else
-NEON_CONF_OPT+=--without-ssl
+NEON_CONF_OPT += --with-libxml2=no
+endif
+
+ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
+# webdav needs xml support
+NEON_CONF_OPT += --disable-webdav
endif
define NEON_REMOVE_CONFIG_SCRIPTS