summaryrefslogtreecommitdiffstats
path: root/package/neon
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2008-04-12 09:56:15 +0000
committerNigel Kukard <nkukard@lbsd.net>2008-04-12 09:56:15 +0000
commit59a9c02e1355bcd630a207e8be319a044597ad1d (patch)
treefd67e6a6123c7da5e88f083320f2d96ae3c15331 /package/neon
parent9fadf8ade54a79427a8ac712e9de974c77bf02fc (diff)
downloadbuildroot-novena-59a9c02e1355bcd630a207e8be319a044597ad1d.tar.gz
buildroot-novena-59a9c02e1355bcd630a207e8be319a044597ad1d.zip
* Added neon
Diffstat (limited to 'package/neon')
-rw-r--r--package/neon/Config.in38
-rw-r--r--package/neon/neon.mk25
2 files changed, 63 insertions, 0 deletions
diff --git a/package/neon/Config.in b/package/neon/Config.in
new file mode 100644
index 000000000..8ac9d0811
--- /dev/null
+++ b/package/neon/Config.in
@@ -0,0 +1,38 @@
+config BR2_PACKAGE_NEON
+ bool "libneon"
+ default n
+ help
+ HTTP and WebDAV client library, with a C interface.
+
+ http://www.webdav.org/neon/
+
+choice
+ prompt "XML Support"
+ default BR2_PACKAGE_NEON_NOXML
+ depends BR2_PACKAGE_NEON
+ help
+ Select which XML library to use...
+ expat use exapt
+ libxml2 use libxml2
+ none do not build with XML support
+
+config BR2_PACKAGE_NEON_EXPAT
+ bool "expat"
+ depends BR2_PACKAGE_EXPAT
+ help
+ expat use exapt, a library for parsing XML.
+
+config BR2_PACKAGE_NEON_LIBXML2
+ bool "libxml2"
+ depends BR2_PACKAGE_LIBXML2
+ help
+ libxml2 use libxml2, a library to read, modify and
+ write XML and HTML files.
+
+config BR2_PACKAGE_NEON_NOXML
+ bool "none"
+ help
+ none don't use XML, if this is the only option
+ and you want XML support, you must choose
+ XML handling below.
+endchoice
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
new file mode 100644
index 000000000..36bfb3bb6
--- /dev/null
+++ b/package/neon/neon.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# neon
+#
+#############################################################
+NEON_VERSION = 0.28.2
+NEON_SITE = http://www.webdav.org/neon/
+NEON_INSTALL_STAGING = YES
+
+NEON_CONF_OPT+=--enable-shared --without-gssapi --disable-rpath
+
+NEON_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
+
+ifeq ($(strip $(BR2_PACKAGE_NEON_LIBXML2)),y)
+NEON_CONF_OPT+=--with-libxml2=yes
+NEON_CONF_OPT+=--with-expat=no
+NEON_DEPENDENCIES+=libxml2
+endif
+ifeq ($(strip $(BR2_PACKAGE_NEON_EXPAT)),y)
+NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_CONF_OPT+=--with-libxml2=no
+NEON_DEPENDENCIES+=expat
+endif
+
+$(eval $(call AUTOTARGETS,package,neon))