summaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2008-04-09 11:38:48 +0000
committerNigel Kukard <nkukard@lbsd.net>2008-04-09 11:38:48 +0000
commitd284bd5b8fa545c4d365303a9495b2e0c496ad59 (patch)
treee793c4e9c64e4e6a108f311d2824180061fe3233 /package/ncurses
parent1a09aaf0473d4461625a38f0de29e953cb58feef (diff)
downloadbuildroot-novena-d284bd5b8fa545c4d365303a9495b2e0c496ad59.tar.gz
buildroot-novena-d284bd5b8fa545c4d365303a9495b2e0c496ad59.zip
Some package use ncurses libpanel/libform/libmenu, this config allows to selectively
copy them to the target filesystem at the same time at the main library is installed. -Patch by Michel (BusError)
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/Config.in22
-rw-r--r--package/ncurses/ncurses.mk9
2 files changed, 31 insertions, 0 deletions
diff --git a/package/ncurses/Config.in b/package/ncurses/Config.in
index 9a507686b..e11249e34 100644
--- a/package/ncurses/Config.in
+++ b/package/ncurses/Config.in
@@ -7,6 +7,28 @@ config BR2_PACKAGE_NCURSES
http://www.gnu.org/software/ncurses/
+config BR2_PACKAGE_NCURSES_TARGET_PANEL
+ bool "ncurses libpanel in target"
+ default n
+ depends on BR2_PACKAGE_NCURSES
+ help
+ Ncurses headers in target
+ Includes ncurses dynamic libpanel in target
+
+config BR2_PACKAGE_NCURSES_TARGET_FORM
+ bool "ncurses libform in target"
+ default n
+ depends on BR2_PACKAGE_NCURSES
+ help
+ Includes ncurses dynamic libform in target
+
+config BR2_PACKAGE_NCURSES_TARGET_MENU
+ bool "ncurses libmenu in target"
+ default n
+ depends on BR2_PACKAGE_NCURSES
+ help
+ Includes ncurses dynamic libmenu in target
+
config BR2_PACKAGE_NCURSES_TARGET_HEADERS
bool "ncurses headers in target"
default n
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index ecdf00ebb..f65b77d2b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -104,6 +104,15 @@ $(STAGING_DIR)/lib/libncurses.so.$(NCURSES_VERSION): $(NCURSES_DIR)/lib/libncurs
$(TARGET_DIR)/lib/libncurses.so.$(NCURSES_VERSION): $(STAGING_DIR)/lib/libncurses.so.$(NCURSES_VERSION)
cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
+ifeq ($(strip $(BR2_PACKAGE_NCURSES_TARGET_PANEL)),y)
+ cp -dpf $(NCURSES_DIR)/lib/libpanel.so* $(TARGET_DIR)/lib/
+endif
+ifeq ($(strip $(BR2_PACKAGE_NCURSES_TARGET_FORM)),y)
+ cp -dpf $(NCURSES_DIR)/lib/libform.so* $(TARGET_DIR)/lib/
+endif
+ifeq ($(strip $(BR2_PACKAGE_NCURSES_TARGET_MENU)),y)
+ cp -dpf $(NCURSES_DIR)/lib/libmenu.so* $(TARGET_DIR)/lib/
+endif
ln -sf /usr/share/terminfo $(TARGET_DIR)/usr/lib/terminfo
mkdir -p $(TARGET_DIR)/usr/share/terminfo/x
cp -dpf $(STAGING_DIR)/usr/share/terminfo/x/xterm $(TARGET_DIR)/usr/share/terminfo/x