summaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2011-08-26 15:01:41 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-08-26 15:01:41 +0200
commitbf446513e7e73a2bf68213ebfe9ec4bb1fee2467 (patch)
treed55e726a895ff734b016a28e87a8c2c42d500afe /package/ncurses
parentcb6c2c427838a0ba5dc7bb404734574c9ed6b102 (diff)
downloadbuildroot-novena-bf446513e7e73a2bf68213ebfe9ec4bb1fee2467.tar.gz
buildroot-novena-bf446513e7e73a2bf68213ebfe9ec4bb1fee2467.zip
ncurses: fix hanging installation due to old version of tic
Closes #3685 During installation of ncurses, the 'tic' program from the host is used. In some cases, this version of tic is too old for the data to be processed, and the installation hangs indefinitely (already reported in July 2010, see [1]) With this patch, a static version of tic is built and used during the installation step of target ncurses. This method is based on a similar fix in Gentoo Linux (see [2] for the report and [3] for the solution). [1] http://lists.busybox.net/pipermail/buildroot/2010-July/036100.html [2] http://bugs.gentoo.org/show_bug.cgi?id=249363#c25 [3] http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r2.ebuild [Peter: Install into host, don't tweak path] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index ae3f3fb70..0d425280b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -26,6 +26,7 @@
NCURSES_VERSION = 5.7
NCURSES_SITE = $(BR2_GNU_MIRROR)/ncurses
NCURSES_INSTALL_STAGING = YES
+NCURSES_DEPENDENCIES = host-ncurses
NCURSES_CONF_OPT = \
--with-shared \
@@ -120,4 +121,18 @@ define NCURSES_INSTALL_TARGET_CMDS
$(NCURSES_INSTALL_TARGET_DEVFILES)
endef # NCURSES_INSTALL_TARGET_CMDS
+#
+# On systems with an older version of tic, the installation of ncurses hangs
+# forever. To resolve the problem, build a static version of tic on host
+# ourselves, and use that during installation.
+#
+define HOST_NCURSES_BUILD_CMDS
+ $(MAKE1) -C $(@D) sources
+ $(MAKE) -C $(@D)/progs tic
+endef
+
+HOST_NCURSES_CONF_OPT = \
+ --without-shared
+
$(eval $(call AUTOTARGETS,package,ncurses))
+$(eval $(call AUTOTARGETS,package,ncurses,host))