summaryrefslogtreecommitdiffstats
path: root/package/ncftp
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-25 08:18:35 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-25 08:18:35 +0000
commitd7cb72db645f0901ddeb51c7a559b2a25888e65a (patch)
treeaba73299fd5e7c1a2d005ea0bda0484c995b226c /package/ncftp
parentdf8f9549fdd6a3248efe505e94ca509a32db18f0 (diff)
downloadbuildroot-novena-d7cb72db645f0901ddeb51c7a559b2a25888e65a.tar.gz
buildroot-novena-d7cb72db645f0901ddeb51c7a559b2a25888e65a.zip
Part of NcFTP depends on ncurses, create dependencies, if needed
Diffstat (limited to 'package/ncftp')
-rw-r--r--package/ncftp/Config.in6
-rw-r--r--package/ncftp/ncftp.mk7
2 files changed, 10 insertions, 3 deletions
diff --git a/package/ncftp/Config.in b/package/ncftp/Config.in
index d7c63ba0e..652825de1 100644
--- a/package/ncftp/Config.in
+++ b/package/ncftp/Config.in
@@ -30,11 +30,13 @@ config BR2_PACKAGE_NCFTP_BATCH
depends on BR2_PACKAGE_NCFTP
config BR2_PACKAGE_NCFTP_SPOOLER
- bool "NcFTPSpooler - spooler - not working properly"
+ bool "NcFTPSpooler - spooler"
depends on BR2_PACKAGE_NCFTP
+ depends on BR2_PACKAGE_NCURSES
config BR2_PACKAGE_NCFTP_BOOKMARKS
- bool "NcFTPBookmarks - not working properly"
+ bool "NcFTPBookmarks"
depends on BR2_PACKAGE_NCFTP
+ depends on BR2_PACKAGE_NCURSES
endmenu
diff --git a/package/ncftp/ncftp.mk b/package/ncftp/ncftp.mk
index 70f0fd618..4a4a9a643 100644
--- a/package/ncftp/ncftp.mk
+++ b/package/ncftp/ncftp.mk
@@ -26,15 +26,20 @@ ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
NCFTP_TARGET_BINS+=ncftpbatch
endif
+ifeq ($(BR2_PACKAGE_NCURSES),y)
ifeq ($(BR2_PACKAGE_NCFTP_SPOOLER),y)
#Someone needs to figure out what to do...
NCFTP_TARGET_BINS+=
endif
+# only set if NCURSES is available
ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
NCFTP_TARGET_BINS+=ncftpbookmarks
endif
+NCFTP_DEPS += ncurses
+endif
+
ncftp-source: $(DL_DIR)/$(NCFTP_SOURCE)
$(DL_DIR)/$(NCFTP_SOURCE):
@@ -64,7 +69,7 @@ $(TARGET_DIR)/usr/bin/ncftp $(TARGET_DIR)/usr/bin/ncftp%: $(addprefix $(NCFTP_DI
$(INSTALL) -m 0755 $(NCFTP_DIR)/bin/$(notdir $@) $(TARGET_DIR)/usr/bin
$(STRIPCMD) $(STRIP_STRIP_ALL) $@
-ncftp: uclibc $(addprefix $(TARGET_DIR)/usr/bin/, $(NCFTP_TARGET_BINS))
+ncftp: uclibc $(NCFTP_DEPS) $(addprefix $(TARGET_DIR)/usr/bin/, $(NCFTP_TARGET_BINS))
ncftp-clean:
-$(MAKE) -C $(NCFTP_DIR) clean