summaryrefslogtreecommitdiffstats
path: root/package/nasm
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-31 21:08:14 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-12 13:38:45 +0200
commitda8d09b716a7dea65697efcadd1067d5e9b4f7f7 (patch)
tree04defdc6eefa0f10d96e0a74686f9033328cc6ee /package/nasm
parent77d15d67712956f19258364e8aca81304e960d0e (diff)
downloadbuildroot-novena-da8d09b716a7dea65697efcadd1067d5e9b4f7f7.tar.gz
buildroot-novena-da8d09b716a7dea65697efcadd1067d5e9b4f7f7.zip
nasm: new package, needed for syslinux
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/nasm')
-rw-r--r--package/nasm/nasm.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/nasm/nasm.mk b/package/nasm/nasm.mk
new file mode 100644
index 000000000..08983e158
--- /dev/null
+++ b/package/nasm/nasm.mk
@@ -0,0 +1,19 @@
+############################################################
+#
+# nasm
+#
+# This is special case: nasm is used to build syslinux and
+# pxelinux. As these are for the target, we should cross-compile
+# nasm. However, as nasm is x86-only, there's no point in
+# cross-compiling it. So we just build it for the host. The target
+# variant is only provided because of a bug in the package
+# infrastructure that prevents having only a host variant.
+############################################################
+
+NASM_VERSION=2.08.01
+NASM_SOURCE=nasm-$(NASM_VERSION).tar.bz2
+NASM_SITE=http://www.nasm.us/pub/nasm/releasebuilds/2.08.01/
+NASM_LIBTOOL_PATCH=NO
+
+$(eval $(call AUTOTARGETS,package,nasm))
+$(eval $(call AUTOTARGETS,package,nasm,host))