summaryrefslogtreecommitdiffstats
path: root/package/multimedia
diff options
context:
space:
mode:
authorValentine Barshak <gvaxon@gmail.com>2012-09-26 09:34:51 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-04 23:26:56 +0200
commit63fbc1834f98f37cc43514f13cb75c1034dcf454 (patch)
treea50540eddbe50f3d7c105b67cbe5dc358fe9bd0c /package/multimedia
parentfc2f47e9ae46fcd6385baa5eabae747696127e54 (diff)
downloadbuildroot-novena-63fbc1834f98f37cc43514f13cb75c1034dcf454.tar.gz
buildroot-novena-63fbc1834f98f37cc43514f13cb75c1034dcf454.zip
mplayer: Fix external libdvdread and libdvdnav support
This sets paths to dvdread-config and dvdnav-config, and configuration options to enable external libdvdread and libdvdnav support. Signed-off-by: Valentine Barshak <gvaxon@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/mplayer/mplayer.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index 05120bf78..9ff4b8a62 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -42,6 +42,21 @@ else
MPLAYER_CONF_OPTS += --disable-freetype
endif
+ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
+MPLAYER_CONF_OPTS += \
+ --enable-dvdread \
+ --disable-dvdread-internal \
+ --with-dvdread-config=$(STAGING_DIR)/usr/bin/dvdread-config
+MPLAYER_DEPENDENCIES += libdvdread
+endif
+
+ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
+MPLAYER_CONF_OPTS += \
+ --enable-dvdnav \
+ --with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
+MPLAYER_DEPENDENCIES += libdvdnav
+endif
+
ifeq ($(BR2_PACKAGE_MPLAYER_MPLAYER),y)
MPLAYER_CONF_OPTS += --enable-mplayer
else