summaryrefslogtreecommitdiffstats
path: root/package/multimedia
diff options
context:
space:
mode:
authorSpenser Gilliland <spenser@gillilanding.com>2013-06-20 17:07:41 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-21 16:05:12 +0200
commit09ed859d5e61f0ac1812340dc471a4dfab8819be (patch)
tree54e2932f4e703c81afecab12d4647af7db7d1b5d /package/multimedia
parent6afdb607cd3741bd4fa6fa0e859f763feccdf28d (diff)
downloadbuildroot-novena-09ed859d5e61f0ac1812340dc471a4dfab8819be.tar.gz
buildroot-novena-09ed859d5e61f0ac1812340dc471a4dfab8819be.zip
gst1-plugins-ugly: add gstreamer1 ugly plugins
Adds gstreamer 1.X ugly plugins [Peter: fix Config.in typo] Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/Config.in1
-rw-r--r--package/multimedia/gst1-plugins-ugly/Config.in69
-rw-r--r--package/multimedia/gst1-plugins-ugly/gst1-plugins-ugly.mk104
3 files changed, 174 insertions, 0 deletions
diff --git a/package/multimedia/Config.in b/package/multimedia/Config.in
index 318dd74d4..c87abea7a 100644
--- a/package/multimedia/Config.in
+++ b/package/multimedia/Config.in
@@ -18,6 +18,7 @@ source "package/multimedia/gst1-plugins-good/Config.in"
source "package/multimedia/gst-plugins-bad/Config.in"
source "package/multimedia/gst1-plugins-bad/Config.in"
source "package/multimedia/gst-plugins-ugly/Config.in"
+source "package/multimedia/gst1-plugins-ugly/Config.in"
source "package/multimedia/gst-plugin-x170/Config.in"
source "package/multimedia/lame/Config.in"
source "package/multimedia/libvpx/Config.in"
diff --git a/package/multimedia/gst1-plugins-ugly/Config.in b/package/multimedia/gst1-plugins-ugly/Config.in
new file mode 100644
index 000000000..a6ca387c6
--- /dev/null
+++ b/package/multimedia/gst1-plugins-ugly/Config.in
@@ -0,0 +1,69 @@
+menuconfig BR2_PACKAGE_GST1_PLUGINS_UGLY
+ bool "gst1-plugins-ugly"
+ depends on BR2_PACKAGE_GSTREAMER1
+ select BR2_PACKAGE_GST1_PLUGINS_BASE
+ help
+ A set of well-supported plug-ins for GStreamer, but might pose
+ problems for distributors.
+
+ http://gstreamer.freedesktop.org/
+
+if BR2_PACKAGE_GST1_PLUGINS_UGLY
+
+comment "dependency-less plugins"
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_ASFDEMUX
+ bool "asfdemux"
+ help
+ Demuxes and muxes audio and video in Microsofts ASF format
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDLPCMDEC
+ bool "dvdlpcmdec"
+ help
+ Decode DVD LPCM frames into standard PCM
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDSUB
+ bool "dvdsub"
+ help
+ DVD subtitle parser and decoder
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_XINGMUX
+ bool "xingmux"
+ help
+ Add XING tags to mpeg audio files
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_REALMEDIA
+ bool "realmedia"
+ help
+ RealMedia support plugins
+
+comment "plugins with external dependencies (there may be more available)"
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD
+ bool "dvdread"
+ select BR2_PACKAGE_LIBDVDREAD
+ help
+ Access a DVD with dvdread
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME
+ bool "lame (*.mp3 audio encoder)"
+ select BR2_PACKAGE_LAME
+ help
+ Encode MP3s with LAME
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD
+ bool "mad (*.mp3 audio)"
+ select BR2_PACKAGE_LIBID3TAG
+ select BR2_PACKAGE_LIBMAD
+ help
+ mp3 decoding based on the mad library
+
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPEG2DEC
+ bool "mpeg2dec"
+ select BR2_PACKAGE_LIBMPEG2
+ help
+ LibMpeg2 decoder
+
+# Note: to get descriptions use the following.
+# # find . -name 'plugin-*.xml' | xargs grep -m 1 description
+endif
diff --git a/package/multimedia/gst1-plugins-ugly/gst1-plugins-ugly.mk b/package/multimedia/gst1-plugins-ugly/gst1-plugins-ugly.mk
new file mode 100644
index 000000000..67761b5d8
--- /dev/null
+++ b/package/multimedia/gst1-plugins-ugly/gst1-plugins-ugly.mk
@@ -0,0 +1,104 @@
+###############################################################################
+#
+# gst1-plugins-ugly
+#
+###############################################################################
+
+GST1_PLUGINS_UGLY_VERSION = 1.0.7
+GST1_PLUGINS_UGLY_SOURCE = gst-plugins-ugly-$(GST1_PLUGINS_UGLY_VERSION).tar.xz
+GST1_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
+GST1_PLUGINS_UGLY_LICENSE_FILES = COPYING
+# GPL licensed plugins will append to GST1_PLUGINS_UGLY_LICENSE if enabled.
+GST1_PLUGINS_UGLY_LICENSE = LGPLv2.1+
+
+GST1_PLUGINS_UGLY_CONF_OPT = \
+ --disable-examples \
+ --disable-debug \
+ --disable-valgrind
+
+GST_PLUGINS_BAD1_CONF_OPT += \
+ --disable-a52dec \
+ --disable-amrnb \
+ --disable-amrwb \
+ --disable-cdio \
+ --disable-sidplay \
+ --disable-twolame \
+ --disable-x264
+
+GST1_PLUGINS_UGLY_DEPENDENCIES = gstreamer1 gst1-plugins-base
+
+ifeq ($(BR2_PACKAGE_ORC),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-orc
+GST1_PLUGINS_UGLY_DEPENDENCIES += orc
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_ASFDEMUX),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-asfdemux
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-asfdemux
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDLPCMDEC),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-dvdlpcmdec
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-dvdlpcmdec
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDSUB),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-dvdsub
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-dvdsub
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_UGL1_PLUGIN_XINGMUX),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-xingmux
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-xingmux
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_REALMEDIA),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-realmedia
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-realmedia
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-dvdread
+GST1_PLUGINS_UGLY_DEPENDENCIES += libdvdread
+GST1_PLUGINS_UGLY_HAS_GPL_LICENSE = y
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-dvdread
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-lame
+GST1_PLUGINS_UGLY_DEPENDENCIES += lame
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-lame
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MAD),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-mad
+GST1_PLUGINS_UGLY_DEPENDENCIES += libid3tag libmad
+GST1_PLUGINS_UGLY_HAS_GPL_LICENSE = y
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-mad
+endif
+
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPEG2DEC),y)
+GST1_PLUGINS_UGLY_CONF_OPT += --enable-mpeg2dec
+GST1_PLUGINS_UGLY_DEPENDENCIES += libmpeg2
+GST1_PLUGINS_ULGY_HAS_GPL_LICENSE = y
+else
+GST1_PLUGINS_UGLY_CONF_OPT += --disable-mpeg2dec
+endif
+
+# Add GPL license if GPL plugins enabled.
+ifeq ($(GST1_PLUGINS_UGLY_HAS_GPL_LICENSE),y)
+GST1_PLUGINS_UGLY_LICENSE += GPLv2
+endif
+
+# Use the following command to extract license info for plugins.
+# # find . -name 'plugin-*.xml' | xargs grep license
+
+$(eval $(autotools-package))