summaryrefslogtreecommitdiffstats
path: root/package/multimedia/pulseaudio/pulseaudio.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-05-09 07:14:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-10 20:42:02 +0200
commit2c1a1bb1cd9fd2bd46f2d32f98a8ffc6b536b983 (patch)
tree0507f53ed65367cc939522cd2f1923466b1e8033 /package/multimedia/pulseaudio/pulseaudio.mk
parentecd0f65af92c224d9d17450ffdef00bd929bcfdf (diff)
downloadbuildroot-novena-2c1a1bb1cd9fd2bd46f2d32f98a8ffc6b536b983.tar.gz
buildroot-novena-2c1a1bb1cd9fd2bd46f2d32f98a8ffc6b536b983.zip
pulseaudio: link against json-c
Add an upstream patch that makes Pulseaudio link against json-c instead of json, so that it works with json-c 0.11, and doesn't cause problems with libjson has been also installed in the system. Note that this fix has been merged in Pulseaudio after the 3.0 release, so we will have to keep this patch around when bumping to 3.0. Fixes http://autobuild.buildroot.org/results/91ffd3196092c48b88f59adb12741b3f93064dea/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/pulseaudio/pulseaudio.mk')
-rw-r--r--package/multimedia/pulseaudio/pulseaudio.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/multimedia/pulseaudio/pulseaudio.mk b/package/multimedia/pulseaudio/pulseaudio.mk
index 16df85555..aa67592d2 100644
--- a/package/multimedia/pulseaudio/pulseaudio.mk
+++ b/package/multimedia/pulseaudio/pulseaudio.mk
@@ -32,6 +32,12 @@ PULSEAUDIO_DEPENDENCIES = \
$(if $(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),webrtc-audio-processing) \
$(if $(BR2_PACKAGE_SYSTEMD),systemd)
+# One patch touches configure.ac. We unconditionnally need libglib2
+# because configure.ac uses AM_GLIB_GNU_GETTEXT. This unconditionnal
+# dependency can be removed once the patch is removed.
+PULSEAUDIO_AUTORECONF = YES
+PULSEAUDIO_DEPENDENCIES += libglib2
+
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
# The optional webrtc echo canceller is written in C++, causing auto* to want
# to link module-echo-cancel.so with CXX even if webrtc ISN'T used.