summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mplayer
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-01 13:33:33 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-12-01 13:33:33 +0000
commite3e34dab93a4f22c52a337692d2ec1954cdbfa7c (patch)
treeff55fbe327cf42d28e599a2d744e376b57848f17 /package/multimedia/mplayer
parentfb11bbf5e99d8a04714934bea0b926ecfa3dde45 (diff)
downloadbuildroot-novena-e3e34dab93a4f22c52a337692d2ec1954cdbfa7c.tar.gz
buildroot-novena-e3e34dab93a4f22c52a337692d2ec1954cdbfa7c.zip
mplayer: use $(if ...) to add dependencies to mplayer
This patch will add needed libraries with $(if ...) syntax. This should ease readability and make it easy for others to spot where the depencies are added. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/multimedia/mplayer')
-rw-r--r--package/multimedia/mplayer/mplayer.mk8
1 files changed, 1 insertions, 7 deletions
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index 350c6b06c..90ac630a0 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -17,12 +17,6 @@ else
MPLAYER_ENDIAN:=--disable-big-endian
endif
-MPLAYER_DEP_LIBS:=libmad
-
-ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
-MPLAYER_DEP_LIBS+=alsa-lib
-endif
-
$(DL_DIR)/$(MPLAYER_SOURCE):
$(WGET) -P $(DL_DIR) $(MPLAYER_SITE)/$(MPLAYER_SOURCE)
@@ -66,7 +60,7 @@ $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY): $(MPLAYER_DIR)/$(MPLAYER_BINARY)
-$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
touch -c $@
-mplayer: uclibc $(MPLAYER_DEP_LIBS) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
+mplayer: uclibc $(if $(BR2_PACKAGE_LIBMAD),libmad) $(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
mplayer-source: $(DL_DIR)/$(MPLAYER_SOURCE)