summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mplayer
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-11-04 13:09:14 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-04 13:10:23 +0100
commit209b3425314a868dca9bb21191881d2252b626e6 (patch)
tree153619048344dbb3b94eb5cca0c1dc0ed0f50dab /package/multimedia/mplayer
parent0dca70656855c1a343f0351e4e69ac6a2c112472 (diff)
downloadbuildroot-novena-209b3425314a868dca9bb21191881d2252b626e6.tar.gz
buildroot-novena-209b3425314a868dca9bb21191881d2252b626e6.zip
mplayer: tighten alsa dependency
mplayer needs pcm+mixer support in alsa, but this isn't checked by configure, so do it in mplayer.mk instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/mplayer')
-rw-r--r--package/multimedia/mplayer/mplayer.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index ac3a67e1d..93e38dab8 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -11,9 +11,15 @@ MPLAYER_CAT:=$(BZCAT)
MPLAYER_BINARY:=mplayer
MPLAYER_TARGET_BINARY:=usr/bin/$(MPLAYER_BINARY)
-MPLAYER_DEPENDENCIES = \
- $(if $(BR2_PACKAGE_LIBMAD),libmad) \
- $(if $(BR2_PACKAGE_ALSA_LIB),alsa-lib)
+MPLAYER_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBMAD),libmad)
+
+# mplayer needs pcm+mixer support, but configure fails to check for it
+ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+MPLAYER_DEPENDENCIES += alsa-lib
+MPLAYER_ALSA:=--enable-alsa
+else
+MPLAYER_ALSA:=--disable-alsa
+endif
ifeq ($(BR2_ENDIAN),"BIG")
MPLAYER_ENDIAN:=--enable-big-endian
@@ -84,6 +90,7 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
$(MPLAYER_LARGEFILE) \
$(MPLAYER_SDL) \
$(MPLAYER_FREETYPE) \
+ $(MPLAYER_ALSA) \
--enable-cross-compile \
--disable-ivtv \
--disable-tv \