summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mpd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-02-10 14:58:14 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-10 22:47:19 +0100
commita74b4044b00b19055474c3d3dc2c069fc26a38c0 (patch)
treefea184699b55eaf85038a7356e5472e612eec1fd /package/multimedia/mpd
parentb92f5b7307aea2512077bf8588ac6e105dc79f3f (diff)
downloadbuildroot-novena-a74b4044b00b19055474c3d3dc2c069fc26a38c0.tar.gz
buildroot-novena-a74b4044b00b19055474c3d3dc2c069fc26a38c0.zip
mpd: new features
* Add libcue support (.cue file parsing) * Add lame support (mp3 encoding) * Fix slight typo in Config.in wrt LIBCUEFILE Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/mpd')
-rw-r--r--package/multimedia/mpd/Config.in14
-rw-r--r--package/multimedia/mpd/mpd.mk12
2 files changed, 25 insertions, 1 deletions
diff --git a/package/multimedia/mpd/Config.in b/package/multimedia/mpd/Config.in
index 3906a5f93..e418d32c1 100644
--- a/package/multimedia/mpd/Config.in
+++ b/package/multimedia/mpd/Config.in
@@ -53,6 +53,18 @@ config BR2_PACKAGE_MPD_FLAC
Enable flac input/streaming support.
Select this if you want to play back FLAC files.
+config BR2_PACKAGE_MPD_LAME
+ bool "lame"
+ select BR2_PACKAGE_LAME
+ help
+ Enable lame (mp3) encoding support.
+
+config BR2_PACKAGE_MPD_LIBCUE
+ bool "libcue"
+ select BR2_PACKAGE_LIBCUE
+ help
+ Enable cue file support.
+
config BR2_PACKAGE_MPD_LIBSAMPLERATE
bool "libsamplerate"
select BR2_PACKAGE_LIBSAMPLERATE
@@ -86,7 +98,7 @@ config BR2_PACKAGE_MPD_MPG123
config BR2_PACKAGE_MPD_MUSEPACK
bool "musepack"
- select BR2_PACKAGE_LIBCUE
+ select BR2_PACKAGE_LIBCUEFILE
select BR2_PACKAGE_LIBREPLAYGAIN
select BR2_PACKAGE_MUSEPACK
help
diff --git a/package/multimedia/mpd/mpd.mk b/package/multimedia/mpd/mpd.mk
index 61b107b38..728feaa06 100644
--- a/package/multimedia/mpd/mpd.mk
+++ b/package/multimedia/mpd/mpd.mk
@@ -44,6 +44,18 @@ else
MPD_CONF_OPT += --disable-curl
endif
+ifeq ($(BR2_PACKAGE_MPD_LAME),y)
+MPD_DEPENDENCIES += lame
+else
+MPD_CONF_OPT += --disable-lame-encoder
+endif
+
+ifeq ($(BR2_PACKAGE_MPD_LIBCUE),y)
+MPD_DEPENDENCIES += libcue
+else
+MPD_CONF_OPT += --disable-cue
+endif
+
ifeq ($(BR2_PACKAGE_MPD_LIBSAMPLERATE),y)
MPD_DEPENDENCIES += libsamplerate
else