summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mpd
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-04-03 22:51:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-03 22:51:54 +0200
commit4d1118e2d83bcb3d5777f86e560086eaf60b0322 (patch)
treea62542ceaabdeb68b048ddaf90edf20cf062cb03 /package/multimedia/mpd
parenta219ed3f7b81b93b4ed394451e7dbf862f678ec1 (diff)
downloadbuildroot-novena-4d1118e2d83bcb3d5777f86e560086eaf60b0322.tar.gz
buildroot-novena-4d1118e2d83bcb3d5777f86e560086eaf60b0322.zip
mpd: fix build with tremor support
Tremor needs the common ogg support (in _ogg_common.c) to get built, similar to how it is done when libvorbis is used. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/mpd')
-rw-r--r--package/multimedia/mpd/mpd-0.16.2-tremor-needs-ogg_common.patch20
-rw-r--r--package/multimedia/mpd/mpd.mk1
2 files changed, 21 insertions, 0 deletions
diff --git a/package/multimedia/mpd/mpd-0.16.2-tremor-needs-ogg_common.patch b/package/multimedia/mpd/mpd-0.16.2-tremor-needs-ogg_common.patch
new file mode 100644
index 000000000..d315f146d
--- /dev/null
+++ b/package/multimedia/mpd/mpd-0.16.2-tremor-needs-ogg_common.patch
@@ -0,0 +1,20 @@
+[PATCH] configure: tremor needs common ogg support just like libvorbis does
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: mpd-0.16.2/configure.ac
+===================================================================
+--- mpd-0.16.2.orig/configure.ac
++++ mpd-0.16.2/configure.ac
+@@ -1081,7 +1081,7 @@
+ fi
+
+ AM_CONDITIONAL(HAVE_OGG_COMMON,
+- test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
++ test x$enable_vorbis = xyes || test x$enable_tremor = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
+
+ AM_CONDITIONAL(HAVE_FLAC_COMMON,
+ test x$enable_flac = xyes || test x$enable_oggflac = xyes)
diff --git a/package/multimedia/mpd/mpd.mk b/package/multimedia/mpd/mpd.mk
index 3f5057c87..d418f61d6 100644
--- a/package/multimedia/mpd/mpd.mk
+++ b/package/multimedia/mpd/mpd.mk
@@ -6,6 +6,7 @@
MPD_VERSION = 0.16.2
MPD_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/musicpd
+MPD_AUTORECONF = YES
MPD_DEPENDENCIES = host-pkg-config libglib2
# Some options need an explicit --disable or --enable