summaryrefslogtreecommitdiffstats
path: root/package/multimedia/gst-plugins-good
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-10-20 21:21:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-21 23:04:20 +0200
commit7a3fa3efa151e4a7e5f68857917bc18ba944745e (patch)
tree0cd8fc147d329faf5774510559faa72719739f52 /package/multimedia/gst-plugins-good
parent61901bd74a622450139358ea0c0f37d4568ad570 (diff)
downloadbuildroot-novena-7a3fa3efa151e4a7e5f68857917bc18ba944745e.tar.gz
buildroot-novena-7a3fa3efa151e4a7e5f68857917bc18ba944745e.zip
gst-plugins-good: make new dependency-less plugins configurable
gst-plugins-good gained a number of dependency-less plugins with the last update. This commit makes them configurable in buildroot. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/gst-plugins-good')
-rw-r--r--package/multimedia/gst-plugins-good/Config.in16
-rw-r--r--package/multimedia/gst-plugins-good/gst-plugins-good.mk32
2 files changed, 42 insertions, 6 deletions
diff --git a/package/multimedia/gst-plugins-good/Config.in b/package/multimedia/gst-plugins-good/Config.in
index b96f15d97..fdb6646ae 100644
--- a/package/multimedia/gst-plugins-good/Config.in
+++ b/package/multimedia/gst-plugins-good/Config.in
@@ -61,8 +61,11 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AVI
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_CUTTER
bool "cutter"
-config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUG
- bool "debug"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUGUTILS
+ bool "debugutils"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEINTERLACE
+ bool "deinterlace"
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EFFECTV
bool "effectv"
@@ -70,6 +73,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EFFECTV
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EQUALIZER
bool "equalizer"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLV
+ bool "flv"
+
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX
bool "id3demux (*.mp3 audio)"
@@ -115,6 +121,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_REPLAYGAIN
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTP
bool "rtp"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTPMANAGER
+ bool "rtpmanager"
+
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTSP
bool "rtsp"
@@ -143,6 +152,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE
bool "wavparse (*.wav audio)"
default y
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_Y4M
+ bool "y4m"
+
comment "plugins with external dependencies"
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX
diff --git a/package/multimedia/gst-plugins-good/gst-plugins-good.mk b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
index 4f4861b15..7b6f02bea 100644
--- a/package/multimedia/gst-plugins-good/gst-plugins-good.mk
+++ b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
@@ -10,8 +10,8 @@ GST_PLUGINS_GOOD_LIBTOOL_PATCH = NO
GST_PLUGINS_GOOD_CONF_OPT = \
$(DISABLE_NLS) \
+ --disable-debug \
--disable-examples \
- --disable-directdraw \
--disable-directsound \
--disable-sunaudio \
--disable-osx_audio \
@@ -105,10 +105,16 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-cutter
endif
-ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUG),y)
-GST_PLUGINS_GOOD_CONF_OPT += --enable-debug
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUGUTILS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-debugutils
else
-GST_PLUGINS_GOOD_CONF_OPT += --disable-debug
+GST_PLUGINS_GOOD_CONF_OPT += --disable-debugutils
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEINTERLACE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-deinterlace
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-deinterlace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EFFECTV),y)
@@ -123,6 +129,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-equalizer
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLV),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-flv
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-flv
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-id3demux
else
@@ -213,6 +225,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-rtp
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTPMANAGER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-rtpmanager
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-rtpmanager
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTSP),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-rtsp
else
@@ -267,6 +285,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-wavparse
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_Y4M),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-y4m
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-y4m
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-annodex
GST_PLUGINS_GOOD_DEPENDENCIES += libxml2