summaryrefslogtreecommitdiffstats
path: root/package/multimedia/gst-plugins-base
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2012-12-20 00:49:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-05 12:55:48 +0100
commit1a18a456f223562446c0ea2364109a05faae1bc1 (patch)
tree8795e8e5e06103e0df693635b8493f4cdf8f4cea /package/multimedia/gst-plugins-base
parent77c70467154c8349ea4af8cf0aa4ff6b79b3af68 (diff)
downloadbuildroot-novena-1a18a456f223562446c0ea2364109a05faae1bc1.tar.gz
buildroot-novena-1a18a456f223562446c0ea2364109a05faae1bc1.zip
gst-plugins-base: make alsa plug-in configurable
It may be desirable not to use the alsa sink for playback even though alsa-lib is installed. So make this a configuration option. This also takes care of selecting the proper options for alsa-lib (BR2_PACKAGE_ALSA_LIB_MIXER and BR2_PACKAGE_ALSA_LIB_PCM). [Peter: fix indentation] Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/gst-plugins-base')
-rw-r--r--package/multimedia/gst-plugins-base/Config.in6
-rw-r--r--package/multimedia/gst-plugins-base/gst-plugins-base.mk3
2 files changed, 7 insertions, 2 deletions
diff --git a/package/multimedia/gst-plugins-base/Config.in b/package/multimedia/gst-plugins-base/Config.in
index 5d8253395..af4fe8c1e 100644
--- a/package/multimedia/gst-plugins-base/Config.in
+++ b/package/multimedia/gst-plugins-base/Config.in
@@ -73,6 +73,12 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VOLUME
comment "plugins with external dependencies (there may be more available)"
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA
+ bool "alsa (mandatory for audio playback)"
+ select BR2_PACKAGE_ALSA_LIB
+ select BR2_PACKAGE_ALSA_LIB_MIXER
+ select BR2_PACKAGE_ALSA_LIB_PCM
+
config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG
bool "ogg (*.ogg audio/video)"
select BR2_PACKAGE_LIBOGG
diff --git a/package/multimedia/gst-plugins-base/gst-plugins-base.mk b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
index b044516cc..02e7ca41c 100644
--- a/package/multimedia/gst-plugins-base/gst-plugins-base.mk
+++ b/package/multimedia/gst-plugins-base/gst-plugins-base.mk
@@ -40,8 +40,7 @@ ifeq ($(BR2_PACKAGE_ORC),y)
GST_PLUGINS_BASE_DEPENDENCIES += orc
endif
-# alsa support needs pcm+mixer support, but configure fails to check for it
-ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA),y)
GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
else
GST_PLUGINS_BASE_CONF_OPT += --disable-alsa