summaryrefslogtreecommitdiffstats
path: root/package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-10 21:54:59 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-13 16:55:50 +0200
commit3b838d864076ebcd54565c9f91cd62b2b9729ce2 (patch)
tree8d3a3f700150de2746adda2e9d9b7d66fb8ac070 /package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
parent8e4a53cf8c5ddb3f0ea5b8d084e1b8b2b81139d4 (diff)
downloadbuildroot-novena-3b838d864076ebcd54565c9f91cd62b2b9729ce2.tar.gz
buildroot-novena-3b838d864076ebcd54565c9f91cd62b2b9729ce2.zip
aumix: convert to the autotools infrastructure
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch')
-rw-r--r--package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch b/package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
new file mode 100644
index 000000000..8d55218bb
--- /dev/null
+++ b/package/multimedia/aumix/aumix-2.8-fix-incorrect-makefile-am.patch
@@ -0,0 +1,29 @@
+Aumix's src/Makefile.am incorrect adds @includedir@ to the list of
+include paths and @libdir@ to the list of libraries paths. This is
+incorrect, as @includedir@ and @libdir@ are respectively /usr/include
+and /usr/lib, even in cross-compilation mode.
+
+At the same time, use AM_CFLAGS instead of CFLAGS, as is done on the
+similar patch found in OpenEmbedded.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ src/Makefile.am | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+Index: aumix-2.8/src/Makefile.am
+===================================================================
+--- aumix-2.8.orig/src/Makefile.am
++++ aumix-2.8/src/Makefile.am
+@@ -7,9 +7,8 @@
+ mouse.c common.h curses.h gpm-xterm.h gtk.h interactive.h \
+ mouse.h play.xpm record.xpm
+ localedir = $(datadir)/locale
+-INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\" -I@includedir@
+-CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
+-LDADD = -L@libdir@
++INCLUDES = -I../intl -DLOCALEDIR=\"$(localedir)\"
++AM_CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ @GTK_CFLAGS@
+ LIBS = @LIBS@ @GTK_LIBS@ @INTLLIBS@
+ DEFS = @DEFS@
+