summaryrefslogtreecommitdiffstats
path: root/package/mtdev2tuio
diff options
context:
space:
mode:
authorStephan Hoffmann <sho@relinux.de>2012-08-30 04:56:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-30 05:09:50 +0200
commitdafa32b3bd75e9d155d075c796fa5b0ecbb9b11b (patch)
treeedbef4052365b3a6251414f1b289f77c45ba6a8e /package/mtdev2tuio
parentfa6e224e589be3386b9b6b7a9bf25fc26325efa5 (diff)
downloadbuildroot-novena-dafa32b3bd75e9d155d075c796fa5b0ecbb9b11b.tar.gz
buildroot-novena-dafa32b3bd75e9d155d075c796fa5b0ecbb9b11b.zip
mtdev2tuio: new package
mtdev2tuio is a simple application for converting touch events to the standart TUIO 1.1 protocol. https://github.com/olivopaolo/mtdev2tuio [thomas.petazzoni@free-electrons.com: use TARGET_CONFIGURE_OPTS, fix indentation, add dependency on thread support in toolchain] Signed-off-by: Stephan Hoffmann <sho@relinux.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mtdev2tuio')
-rw-r--r--package/mtdev2tuio/Config.in13
-rw-r--r--package/mtdev2tuio/mtdev2tuio.mk29
2 files changed, 42 insertions, 0 deletions
diff --git a/package/mtdev2tuio/Config.in b/package/mtdev2tuio/Config.in
new file mode 100644
index 000000000..74453c486
--- /dev/null
+++ b/package/mtdev2tuio/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_MTDEV2TUIO
+ bool "mtdev2tuio"
+ select BR2_PACKAGE_LIBLO
+ select BR2_PACKAGE_MTDEV
+ depends on BR2_TOOLCHAIN_HAS_THREADS # liblo
+ help
+ mtdev2tuio is a simple application for converting touch
+ events captured from libmtdev to TUIO 1.1
+
+ https://github.com/olivopaolo/mtdev2tuio
+
+comment "mtdev2tuio requires thread support in toolchain"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/mtdev2tuio/mtdev2tuio.mk b/package/mtdev2tuio/mtdev2tuio.mk
new file mode 100644
index 000000000..a86c0bf70
--- /dev/null
+++ b/package/mtdev2tuio/mtdev2tuio.mk
@@ -0,0 +1,29 @@
+#############################################################
+#
+# mtdev2tuio
+#
+#############################################################
+MTDEV2TUIO_VERSION = e1e7378d86
+MTDEV2TUIO_SITE = git://github.com/olivopaolo/mtdev2tuio.git
+MTDEV2TUIO_DEPENDENCIES = mtdev liblo
+MTDEV2TUIO_LICENSE = GPLv3+
+MTDEV2TUIO_LICENSE_FILES = COPYING
+
+# mtdev2tuio Makefile misuses $(LD) as gcc, so we need to override LD
+# here.
+define MTDEV2TUIO_BUILD_CMDS
+ $(MAKE) \
+ $(TARGET_CONFIGURE_OPTS) \
+ LD="$(TARGET_CC)" \
+ -C $(@D)
+endef
+
+define MTDEV2TUIO_INSTALL_TARGET_CMDS
+ $(INSTALL) -D -m 0755 $(@D)/mtdev2tuio $(TARGET_DIR)/usr/bin/mtdev2tuio
+endef
+
+define MTDEV2TUIO_CLEAN_CMDS
+ $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))