summaryrefslogtreecommitdiffstats
path: root/package/msmtp
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 05:46:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-29 20:27:38 +0200
commit72713672cca968c37617512af0cc50f2b4114292 (patch)
tree8c6a0f4a98613ebd442cb65471981bcfaf20b2d7 /package/msmtp
parent7ee5f4483952ccf1625af56a97c38f5b856d5a8c (diff)
downloadbuildroot-novena-72713672cca968c37617512af0cc50f2b4114292.tar.gz
buildroot-novena-72713672cca968c37617512af0cc50f2b4114292.zip
msmtp: new package
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/msmtp')
-rw-r--r--package/msmtp/Config.in10
-rw-r--r--package/msmtp/msmtp.mk28
2 files changed, 38 insertions, 0 deletions
diff --git a/package/msmtp/Config.in b/package/msmtp/Config.in
new file mode 100644
index 000000000..385ad90d2
--- /dev/null
+++ b/package/msmtp/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_MSMTP
+ bool "msmtp"
+ help
+ msmtp is an SMTP client. In the default mode, it transmits a
+ mail to an SMTP server (for example at a free mail provider)
+ which takes care of further delivery.
+
+ Note that msmtp is licensed under GPLv3.
+
+ http://msmtp.sourceforge.net/
diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
new file mode 100644
index 000000000..2c712293d
--- /dev/null
+++ b/package/msmtp/msmtp.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# msmtp
+#
+#############################################################
+
+MSMTP_VERSION = 1.4.27
+MSMTP_SITE = http://downloads.sourceforge.net/project/msmtp/msmtp/$(MSMTP_VERSION)
+MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.bz2
+
+MSMTP_DEPENDENCIES += host-pkg-config
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MSMTP_CONF_OPT += --with-ssl=openssl
+MSMTP_DEPENDENCIES += openssl
+else ifeq ($(BR2_PACKAGE_GNUTLS),y)
+MSMTP_CONF_OPT += --with-ssl=gnutls
+MSMTP_DEPENDENCIES += gnutls
+else
+MSMTP_CONF_OPT += --with-ssl=no
+endif
+
+MSMTP_CONF_OPT += \
+ --without-libidn \
+ --without-libgsasl \
+ --without-gnome-keyring
+
+$(eval $(call AUTOTARGETS))