summaryrefslogtreecommitdiffstats
path: root/package/mpfr
diff options
context:
space:
mode:
authorMaxime Petazzoni <maxime.petazzoni@bulix.org>2010-09-02 12:31:57 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-13 08:18:40 +0200
commitd147b81fda4419ea7307835d39cdb58b965882aa (patch)
tree8099e2a2c709852f16f8c59e9c9ae086adf4d251 /package/mpfr
parent9b2ac9f9acd915d8086f4e74c2be672aa83f0d70 (diff)
downloadbuildroot-novena-d147b81fda4419ea7307835d39cdb58b965882aa.tar.gz
buildroot-novena-d147b81fda4419ea7307835d39cdb58b965882aa.zip
Re-implement the source-check and external-deps targets
The new DL_MODE variable dispatches between the various download implementations of each method (Git, Subversion, Wget) to deal with the normal download (default mode, 'DOWNLOAD'), the source-check ('SOURCE_CHECK') and to show the external dependencies for external-deps ('SHOW_EXTERNAL_DEPS'). For the latter, the legacy script wget-show-external-deps.sh is no longer required as $(WGET) isn't called directly anymore but always through the DOWNLOAD helper. Signed-off-by: Maxime Petazzoni <maxime.petazzoni@bulix.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/mpfr')
-rw-r--r--package/mpfr/mpfr.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/mpfr/mpfr.mk b/package/mpfr/mpfr.mk
index b7b80a5a4..6979a9f76 100644
--- a/package/mpfr/mpfr.mk
+++ b/package/mpfr/mpfr.mk
@@ -21,8 +21,10 @@ MPFR_PATCH_SOURCE:=$(DL_DIR)/$(MPFR_PATCH_FILE)
$(MPFR_PATCH_SOURCE):
$(call DOWNLOAD,$(MPFR_SITE),$(MPFR_PATCH))
+ifeq ($(DL_MODE),DOWNLOAD)
mv $(DL_DIR)/$(MPFR_PATCH) $@
endif
+endif
$(DL_DIR)/$(MPFR_SOURCE):
$(call DOWNLOAD,$(MPFR_SITE),$(MPFR_SOURCE))