summaryrefslogtreecommitdiffstats
path: root/package/mpfr
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-09-24 17:14:31 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-09-24 17:14:31 +0200
commitbdccd7b2e67cc9bfa5a95cb74693bce662293549 (patch)
tree2b328f6caa19cc02cea64249584409288b13ca87 /package/mpfr
parent1f09b42f504bfbfb0ce51a94f1033ce05d8d1f08 (diff)
downloadbuildroot-novena-bdccd7b2e67cc9bfa5a95cb74693bce662293549.tar.gz
buildroot-novena-bdccd7b2e67cc9bfa5a95cb74693bce662293549.zip
mpfr: use patch-kernel to apply downloaded patch
Reported by Emmanuel Riou <riou.emmanuel@googlemail.com>. With the recent change to use $(TOPDIR)/dl as default for $(DL_DIR) (416323e93), DL_DIR is now a relative path (./dl), which breaks the mpfr patch handling as it changes dir. Fix is by using patch-kernel instead of calling patch, which does the right thing. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/mpfr')
-rw-r--r--package/mpfr/mpfr.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/mpfr/mpfr.mk b/package/mpfr/mpfr.mk
index 4bd100cff..b0a3cf8c7 100644
--- a/package/mpfr/mpfr.mk
+++ b/package/mpfr/mpfr.mk
@@ -34,7 +34,7 @@ $(MPFR_DIR)/.unpacked: $(DL_DIR)/$(MPFR_SOURCE) $(MPFR_PATCH_SOURCE)
toolchain/patch-kernel.sh $(MPFR_DIR) package/mpfr/ \*.patch
$(CONFIG_UPDATE) $(@D)
ifneq ($(MPFR_PATCH),)
- ( cd $(MPFR_DIR); patch -p1 -N -Z < $(MPFR_PATCH_SOURCE); )
+ toolchain/patch-kernel.sh $(MPFR_DIR) $(DL_DIR)/ $(MPFR_PATCH_FILE)
endif
touch $@