summaryrefslogtreecommitdiffstats
path: root/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-05 17:39:05 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-22 21:20:26 +0200
commitdcc08e84a5e94e7ffaf52ec4374821e56bb20a34 (patch)
treecf16aaa81327aac98dd1d6c10886955e966d57ff /package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch
parent9497c0fee20ff66b7f128d3246bcee09244207cb (diff)
downloadbuildroot-novena-dcc08e84a5e94e7ffaf52ec4374821e56bb20a34.tar.gz
buildroot-novena-dcc08e84a5e94e7ffaf52ec4374821e56bb20a34.zip
module-init-tools: bump version + convert to autotools
The "remove-index" patch is no longer needed, the newer version of module-init-tools correctly uses strchr(). The "module-init-tools" patch, whose main purpose was to disable the generation of man pages (it requires docbook2man), is replaced by a simpler implementation, module-init-tools-3.11-add-manpages-config-option.patch. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch')
-rw-r--r--package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch b/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch
new file mode 100644
index 000000000..28f51de11
--- /dev/null
+++ b/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch
@@ -0,0 +1,47 @@
+Disable manual pages generation when docbook2man is not available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile.am | 7 ++++++-
+ configure.ac | 7 +++----
+ 2 files changed, 9 insertions(+), 5 deletions(-)
+
+Index: module-init-tools-3.11/Makefile.am
+===================================================================
+--- module-init-tools-3.11.orig/Makefile.am
++++ module-init-tools-3.11/Makefile.am
+@@ -39,7 +39,12 @@
+ MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5
+ MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
+ SGML = $(addprefix doc/, $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
+-dist_man_MANS = $(MAN5) $(MAN8)
++
++if HAVE_DOCBOOKTOMAN
++MANPAGES = $(MAN5) $(MAN8)
++endif
++dist_man_MANS = $(MANPAGES)
++
+ # If they haven't overridden mandir, fix it (never /man!)
+ mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
+
+Index: module-init-tools-3.11/configure.ac
+===================================================================
+--- module-init-tools-3.11.orig/configure.ac
++++ module-init-tools-3.11/configure.ac
+@@ -29,13 +29,12 @@
+ AC_PROG_CC
+ AC_PROG_RANLIB
+
+-AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man, [no],)
+-if test x"$DOCBOOKTOMAN" = xno
++AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man)
++if test x"$DOCBOOKTOMAN" = x
+ then
+ AC_MSG_WARN([docbook2man not found])
+- # fail with a meaningfull error if $DOCBOOKTOMAN called by the makefile
+- DOCBOOKTOMAN=docbook2man
+ fi
++AM_CONDITIONAL([HAVE_DOCBOOKTOMAN], [test "x$DOCBOOKTOMAN" != "x"])
+
+ # Delay adding the zlib_flags until after AC_PROG_CC, so we can distinguish
+ # between a broken cc and a working cc but missing libz.a.