summaryrefslogtreecommitdiffstats
path: root/package/memtester/memtester-makefile-fix.patch
diff options
context:
space:
mode:
authorSimon Dawson <spdawson@gmail.com>2012-06-27 21:52:24 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-20 23:42:41 +0200
commit3d3ec6cfe1d1c0abacce65ba2f494aae98af263e (patch)
tree7fc21f71ee154f5375c2364ceb819c572ddb8ee7 /package/memtester/memtester-makefile-fix.patch
parent7c35ab96d57969b63498865778ea4609aa154af7 (diff)
downloadbuildroot-novena-3d3ec6cfe1d1c0abacce65ba2f494aae98af263e.tar.gz
buildroot-novena-3d3ec6cfe1d1c0abacce65ba2f494aae98af263e.zip
memtester: bump to version 4.3.0
Signed-off-by: Simon Dawson <spdawson@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/memtester/memtester-makefile-fix.patch')
-rw-r--r--package/memtester/memtester-makefile-fix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/memtester/memtester-makefile-fix.patch b/package/memtester/memtester-makefile-fix.patch
new file mode 100644
index 000000000..6f1481bec
--- /dev/null
+++ b/package/memtester/memtester-makefile-fix.patch
@@ -0,0 +1,23 @@
+The a/{b,c} construct doesn't work within make, so let's split the
+creation of the installation directories in two commands.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+Index: memtester-4.2.1/Makefile
+===================================================================
+--- memtester-4.2.1.orig/Makefile
++++ memtester-4.2.1/Makefile
+@@ -25,8 +25,9 @@
+ all: memtester
+
+ install: all
+- mkdir -m 755 -p $(INSTALLPATH)/{bin,man/man8}
++ mkdir -m 755 -p $(INSTALLPATH)/bin
+ install -m 755 memtester $(INSTALLPATH)/bin/
++ mkdir -m 755 -p $(INSTALLPATH)/man/man8
+ gzip -c memtester.8 >memtester.8.gz ; install -m 644 memtester.8.gz $(INSTALLPATH)/man/man8/
+
+ auto-ccld.sh: \