summaryrefslogtreecommitdiffstats
path: root/package/matchbox
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-06-25 10:43:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-01 14:24:47 +0200
commit51ef5b81224c243aa7f937c4690b1a120c81ccbc (patch)
tree5242e0adf211c9fd70490171a51ce51758a9b978 /package/matchbox
parente61606ad39735000e66b6048d9be1b9d27c36bd0 (diff)
downloadbuildroot-novena-51ef5b81224c243aa7f937c4690b1a120c81ccbc.tar.gz
buildroot-novena-51ef5b81224c243aa7f937c4690b1a120c81ccbc.zip
Fix Matchbox build
Several issues were encountered when trying to build Matchbox. This patches fixes these issues : * Selecting BR2_PACKAGE_MATCHBOX should select BR2_PACKAGE_XORG7, otherwise the x11r7 mk files are not included, and matchbox.mk refers to non-existing dependencies (such as xlib_libXtst). * In matchbox.mk, wrong dependencies for Matchbox keyboard. When pango is available, use it through --enable-pango, otherwise, add the dependency to xlib_libXft * Enable AUTORECONF for libXfont and libXft, otherwise the libtool Buildroot patch has no effect, and these packages fail to build without the libtool hack. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/matchbox')
-rw-r--r--package/matchbox/Config.in1
-rw-r--r--package/matchbox/matchbox.mk7
2 files changed, 7 insertions, 1 deletions
diff --git a/package/matchbox/Config.in b/package/matchbox/Config.in
index a5e68f8c9..b57a4a29f 100644
--- a/package/matchbox/Config.in
+++ b/package/matchbox/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_MATCHBOX
bool "MatchBox Window Manager"
select BR2_PACKAGE_XSERVER_XORG_SERVER
+ select BR2_PACKAGE_XORG7
select BR2_PACKAGE_FONTCONFIG
select BR2_PACKAGE_XLIB_LIBXDAMAGE
select BR2_PACKAGE_XLIB_LIBXCURSOR
diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
index 6dfccf853..a3ff222f6 100644
--- a/package/matchbox/matchbox.mk
+++ b/package/matchbox/matchbox.mk
@@ -160,6 +160,8 @@ MATCHBOX_WM_OPTS:=
MATCHBOX_WM_DEPS:=xlib_libXdamage
MATCHBOX_WM_DEPS+=xlib_libXcursor
+MATCHBOX_KB_DEPS:=
+
ifeq ($(BR2_PACKAGE_X11R7_LIBXCOMPOSITE),y)
ifeq ($(BR2_PACKAGE_X11R7_LIBXPM),y)
MATCHBOX_WM_OPTS+=--enable-composite
@@ -199,8 +201,10 @@ endif
ifeq ($(BR2_PACKAGE_PANGO),y)
MATCHBOX_LIB_OPTS+=--enable-pango
MATCHBOX_LIB_DEPS+=pango
+ MATCHBOX_KB_OPTS+=--enable-pango
else
MATCHBOX_LIB_OPTS+=--disable-pango
+ MATCHBOX_KB_DEPS+=xlib_libXft
endif
ifeq ($(BR2_PACKAGE_X11R7_LIBXFT2),y)
@@ -424,6 +428,7 @@ $(MATCHBOX_KB_DIR)/.configured: $(MATCHBOX_KB_DIR)/.unpacked
--with-x \
--x-includes=$(STAGING_DIR)/usr/include/X11 \
--x-libraries=$(STAGING_DIR)/usr/lib \
+ $(MATCHBOX_KB_OPTS) \
)
touch $(MATCHBOX_KB_DIR)/.configured
@@ -610,7 +615,7 @@ matchbox-panel: uclibc matchbox $(TARGET_DIR)/usr/bin/$(MATCHBOX_PL_BIN) $(TARGE
matchbox-desktop: uclibc matchbox $(TARGET_DIR)/usr/bin/$(MATCHBOX_DP_BIN)
-matchbox-keyboard: uclibc matchbox xlib_libXtst $(TARGET_DIR)/usr/lib/$(MATCHBOX_FK_BIN).so $(TARGET_DIR)/usr/bin/$(MATCHBOX_KB_BIN)
+matchbox-keyboard: uclibc matchbox xlib_libXtst $(MATCHBOX_KB_DEPS) $(TARGET_DIR)/usr/lib/$(MATCHBOX_FK_BIN).so $(TARGET_DIR)/usr/bin/$(MATCHBOX_KB_BIN)
matchbox-clean:
rm -f $(TARGET_DIR)/usr/lib/libmb.*