summaryrefslogtreecommitdiffstats
path: root/package/matchbox
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:43 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:12:27 +0200
commit300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49 (patch)
tree4b06e56a40777a04ec56ba16d9b5d08fed84de08 /package/matchbox
parent0849e8193ef429f29945b8c2a54eafc8635e0969 (diff)
downloadbuildroot-novena-300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49.tar.gz
buildroot-novena-300f9c9c9dcf2b47ea89c45d5b1ea05e7305bd49.zip
package: remove useless arguments from AUTOTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the AUTOTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/matchbox')
-rw-r--r--package/matchbox/matchbox-common/matchbox-common.mk2
-rw-r--r--package/matchbox/matchbox-desktop/matchbox-desktop.mk2
-rw-r--r--package/matchbox/matchbox-fakekey/matchbox-fakekey.mk2
-rw-r--r--package/matchbox/matchbox-keyboard/matchbox-keyboard.mk2
-rw-r--r--package/matchbox/matchbox-lib/matchbox-lib.mk2
-rw-r--r--package/matchbox/matchbox-panel/matchbox-panel.mk2
-rw-r--r--package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk2
-rw-r--r--package/matchbox/matchbox-wm/matchbox-wm.mk2
8 files changed, 8 insertions, 8 deletions
diff --git a/package/matchbox/matchbox-common/matchbox-common.mk b/package/matchbox/matchbox-common/matchbox-common.mk
index d35d11bca..0468d997b 100644
--- a/package/matchbox/matchbox-common/matchbox-common.mk
+++ b/package/matchbox/matchbox-common/matchbox-common.mk
@@ -15,4 +15,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-common))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-desktop/matchbox-desktop.mk b/package/matchbox/matchbox-desktop/matchbox-desktop.mk
index d5f61c1f1..611323db2 100644
--- a/package/matchbox/matchbox-desktop/matchbox-desktop.mk
+++ b/package/matchbox/matchbox-desktop/matchbox-desktop.mk
@@ -21,4 +21,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-desktop))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk b/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk
index dc448b8ce..424662659 100644
--- a/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk
+++ b/package/matchbox/matchbox-fakekey/matchbox-fakekey.mk
@@ -20,4 +20,4 @@ MATCHBOX_FAKEKEY_POST_CONFIGURE_HOOKS += MATCHBOX_FAKEKEY_POST_CONFIGURE_FIXES
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-fakekey))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-keyboard/matchbox-keyboard.mk b/package/matchbox/matchbox-keyboard/matchbox-keyboard.mk
index 3d7178d14..558a4f7a2 100644
--- a/package/matchbox/matchbox-keyboard/matchbox-keyboard.mk
+++ b/package/matchbox/matchbox-keyboard/matchbox-keyboard.mk
@@ -28,4 +28,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-keyboard))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-lib/matchbox-lib.mk b/package/matchbox/matchbox-lib/matchbox-lib.mk
index 817a8da8f..b0be393d3 100644
--- a/package/matchbox/matchbox-lib/matchbox-lib.mk
+++ b/package/matchbox/matchbox-lib/matchbox-lib.mk
@@ -55,4 +55,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-lib))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-panel/matchbox-panel.mk b/package/matchbox/matchbox-panel/matchbox-panel.mk
index 573e3231d..fe43cb991 100644
--- a/package/matchbox/matchbox-panel/matchbox-panel.mk
+++ b/package/matchbox/matchbox-panel/matchbox-panel.mk
@@ -21,4 +21,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-panel))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk
index 954709a82..2540e4b50 100644
--- a/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk
+++ b/package/matchbox/matchbox-startup-monitor/matchbox-startup-monitor.mk
@@ -12,4 +12,4 @@ MATCHBOX_STARTUP_MONITOR_CONF_OPT =
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-startup-monitor))
+$(eval $(call AUTOTARGETS))
diff --git a/package/matchbox/matchbox-wm/matchbox-wm.mk b/package/matchbox/matchbox-wm/matchbox-wm.mk
index 0334d0f0c..4b3207376 100644
--- a/package/matchbox/matchbox-wm/matchbox-wm.mk
+++ b/package/matchbox/matchbox-wm/matchbox-wm.mk
@@ -39,4 +39,4 @@ endif
#############################################################
-$(eval $(call AUTOTARGETS,package/matchbox,matchbox-wm))
+$(eval $(call AUTOTARGETS))