summaryrefslogtreecommitdiffstats
path: root/package/matchbox/matchbox.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/matchbox/matchbox.mk
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
downloadbuildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.tar.gz
buildroot-novena-77754571b2f327636ce0072cfabc9ce0c9a6ad86.zip
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/matchbox/matchbox.mk')
-rw-r--r--package/matchbox/matchbox.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/matchbox/matchbox.mk b/package/matchbox/matchbox.mk
index e2e4e0ed5..6dfccf853 100644
--- a/package/matchbox/matchbox.mk
+++ b/package/matchbox/matchbox.mk
@@ -604,7 +604,7 @@ $(TARGET_DIR)/usr/bin/$(MATCHBOX_KB_BIN): $(STAGING_DIR)/usr/bin/$(MATCHBOX_KB_B
cp -af $(STAGING_DIR)/usr/share/matchbox/matchbox-keyboard $(TARGET_DIR)/usr/share/matchbox/
cp -dpf ./package/matchbox/mb-applet-kbd-wrapper.sh $(TARGET_DIR)/usr/bin/
-matchbox: uclibc pkgconfig expat $(MATCHBOX_WM_DEPS) $(MATCHBOX_SNOTIFY_DEPS) $(MATCHBOX_LIB_DEPS) $(TARGET_DIR)/usr/lib/libmb.so $(TARGET_DIR)/usr/bin/$(MATCHBOX_WM_BIN)
+matchbox: uclibc host-pkgconfig expat $(MATCHBOX_WM_DEPS) $(MATCHBOX_SNOTIFY_DEPS) $(MATCHBOX_LIB_DEPS) $(TARGET_DIR)/usr/lib/libmb.so $(TARGET_DIR)/usr/bin/$(MATCHBOX_WM_BIN)
matchbox-panel: uclibc matchbox $(TARGET_DIR)/usr/bin/$(MATCHBOX_PL_BIN) $(TARGET_DIR)/usr/bin/matchbox-session $(MATCHBOX_PANEL_DEPS)